After certain upgrades, upon restart of the Content Router, small (1-13 byte) segments are not loaded into the cache which may cause queue processing failures and data loss
| Article:TECH159757 | | | Created: 2011-05-10 | | | Updated: 2011-06-24 | | | Article URL http://www.symantec.com/docs/TECH159757 |
Problem
After upgrading to PureDisk 6.6.1 or NetBackup 7.1, a potential exists for attempts to replicate or restore from backups to fail because their fingerprints are not loaded into the cache.
Environment
What is Affected:
This issue may be seen after one of the following upgrade paths has been taken or when replicating between versions following these paths:
- NetBackup 7.0 to 7.1
- NetBackup 7.0.1 to 7.1
- PureDisk 6.6 to 6.6.1
- PureDisk 6.6 to 6.6.1.2
- PureDisk 6.6.0.x to 6.6.1
- PureDisk 6.6.0.x to 6.6.1.2
Note: NetBackup 5000/5020 1.3 Appliances are affected by this issue, as they are based on PureDisk 6.6.1.2. This issue was resolved in 1.3.0.1.
Initial installations of PureDisk 6.6.1 or NetBackup 7.1 (where no upgrade has taken place and no replications from previous versions are targeted) are also NOT affected by this issue.
Cause
Small segments may be generated when optimized synthetic backups are configured AND the first file in a backup is smaller than 14 bytes. After one of the upgrade paths above has been followed, any fingerprints of these small segments are not loaded into the content router cache. This can cause lookups to fail and prevent replication of (and restoration from) affected backups.
Solution
The formal resolution to this issue (Etrack 2370049) is included in the following release:
- NetBackup 7.1 Maintenance Release 1 (7.1.0.1)
This release is available via the download links provided in the article linked in the "Related Articles" section below.
The formal resolution to this issue is scheduled for inclusion in a future release of PureDisk.
Emergency Engineering Binaries (EEBs) may also be available if the latest available version of the product is already deployed within the environment. This article will be republished with updates - to track updates, please subscribe to this article following the instructions below.
Workaround:
Do not upgrade to an affected version unless an EEB or hotfix can immediately be applied after the upgrade.
If an upgrade has already taken place, disable compaction on the Content Router until one of the following fixes can be implemented:
- Apply the relevant EEB to the NetBackup 7.1 or PureDisk 6.6.1.x environment
- Apply the release update/hotfix containing the fix
Note: Depending on how long it has been since the upgrade, applying a fix (EEB, hotfix or maintenance release) may not completely resolve this issue. It may be necessary to contact Symantec technical support to determine if additional action may be needed.
Best Practices:
Symantec strongly recommends the following best practices:
1. Always perform a full DR backup prior to making any changes to your environment.
2. Always make sure that your environment is running the latest version and patch level.
3. Perform periodic "test" restores.
4. Subscribe to technical articles.
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Software Alerts:
If you have not received this TechNote from the Symantec Email Notification Service as a Software Alert, you may subscribe via email and/or RSS using the links provided at the following page:
NetBackup Enterprise Server: http://www.symantec.com/business/support/index?page=content&key=15143&channel=ALERTS
NetBackup PureDisk: http://www.symantec.com/business/support/index?page=content&key=52672&channel=ALERTS
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| Source | ETrack |
| Value | 2370049 |
| Description | When the Content Router is restarted, segments smaller than 14 bytes are not loaded into the cache; this causes Content Router Queue Processing failures |
Article URL http://www.symantec.com/docs/TECH159757
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