When using frequency schedules, manually restarting a failed job from the Activity Monitor does not cause NetBackup to recalculate which schedule should be used for the "next" backup. This may lead to an additional full backup taken when an incremental backup was expected.

Article:TECH161395  |  Created: 2011-06-01  |  Updated: 2012-04-03  |  Article URL http://www.symantec.com/docs/TECH161395
Article Type
Technical Solution

Product(s)

Environment

Issue



For frequency based schedules:

Scenario: A policy has a FULL weekly backup and a daily INCR (incremental) backup.

The FULL and INCR backup schedule has an open window from 10pm to 2am.

If the FULL backup fails to start and falls outside of the open backup window, the backup will fail with a Status Code 196.

If that failed FULL job is manually restarted from the activity monitor, and completes successfully before the next scheduled window, NetBackup will run another FULL backup instead of the next schedule in the policy. In this scenario, the INCR backup is the next scheduled but did not run because the scheduler (NBPEM - NetBackup Policy Execution Manager) did not recalculate the schedule after the FULL backup successfully completed.


Error



No error message is displayed.

The client will record back-to-back FULL backups.


Environment



NetBackup 7.0.1

Master server 2.6.18-189.el5, x86_64. Linux RedHat 2.6


Cause



From the Symantec NetBackup™ Administrator's Guide, Volume I, Windows, Release 7.0.

Page 527.

Events that cause the schedules to be recalculated:
 

Any one of the following actions causes NetBackup to recalculate which schedule to run next in a policy:
* When a backup job finishes.

In this condition, the manual restart and job completion did not recalculate which schedule to run next in a policy.
In the scenario above, the FULL backup ran a second time because NetBackup did not recalculate after the restarted FULL backup completed successfully.

With the successful completion, the INCR schedule should be next to run.


Solution



The formal resolution to this issue (Etrack 2348002) is included in the following releases:

  • NetBackup 7.1 Maintenance Release 4 (7.1.0.4)
  • NetBackup 7.5

More information on these releases is available at the following link:
 http://www.symantec.com/business/support/overview.jsp?pid=15143

Workaround:
To prevent back-to-back FULL backup jobs,  do not restart the job from the activity monitor but instead manually execute the FULL backup directly from the policy.


Supplemental Materials

SourceETrack
Value2348002
Description

nbpem ASSERT and core at getLBDNoRefCnt after policy update




Article URL http://www.symantec.com/docs/TECH161395


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