Backup Jobs go into queued status when attempting to mount or span media that is scratch or overwritable media.

Article:TECH162081  |  Created: 2011-06-11  |  Updated: 2011-07-13  |  Article URL http://www.symantec.com/docs/TECH162081
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Article Type
Technical Solution


Problem



 

When running a backup job it may go into a Queued status when attempting to mount the next piece of media to continue the job.   The job will remain queued with no further byte count and the time on the job incrementing. The job will remain in this state even when overwritable or scratch media is available in the targeted tape library.

  

 


 


Error



 

Error - Mount failed.
Operation aborted

 


Environment



 

Backup Exec 2010 R2

Spectra Logic Library with Hardware Library partitioning enabled

See the Backup Exec (HCL) Hardware Compatibility List for more information Library partitioning. ( http://entsupport.symantec.com/umi/V-269-1 )

 

Single Spectra Logic Library ( 160 Slots and 8 tape drives) hardware partitioned into Two Libraries as follows:

Library 1 - Spectra 0001 2 Tape drives 40 Slots 
Library 2 - Spectra 0002 6 Tape drives 120 Slots 

 

NDMP Agent Option
NDMP Backups

 


Cause



In the above environment the Spectra Logic Hardware Library partitioning was changed from a configuration of Library 1 ( 2 Tape drives x 60 slots) and Library 2 (6 Tape drives x 100 slots) to a configuration matching the environment section of this technote.  The hardware library partitioning was change to a configuration of Library 1 (2 Tape drive x 40 slots) and Library 2 (6 Tape drives x 120 slots) without fully inventorying both Parts of the library after the hardware change.  An inventory was only performed on Library 1 after the hardware change.

Any job that ran on Library 1 Library ( 2 Tape drives x 40 slots) would write to the first tape and when spanning to the next tape the job would go to Queued.  Debugging Backup Exec with the Backup Exec Live Debugger tool (SGMON) it was found the job was looking for a slot that not longer existed in LIbrary 1 of the library.  The job was requesting or looking for media in Slot 51 which did exist in LIbrary 1 of the library before the hardware library partitioning was changed. 

 

SGMON LOG

PVLSVR:      PvlSession::MountOverwriteMedia() - 0178 priority overwriteable media after blank/unknown
PVLSVR:      PvlSession::MountOverwriteMedia() - 0178 priority overwritable media after standalone
PVLSVR:      PvlSession::MountOverwriteMedia() - qualified drive IBM 0001 slot 0051

PVLSVR:     [6720]     PvlChanger::MountMedia()
            Session = {38E4128F-445F-46AC-90C2-B23C57A79575}
            Library = {075C1128-2CF2-4935-9D9D-E426B138E3F3}, "SPECTRA 0001"
            Drive = {BD1AAA53-C2F7-4377-B3E5-24A00BEB6541}, "IBM 0001"
            Slot = 0051
            Side = 0001
PVLSVR:     [6720]     PvlChanger::ReadSlotInfo()
            Session = {38E4128F-445F-46AC-90C2-B23C57A79575}
            Library = {075C1128-2CF2-4935-9D9D-E426B138E3F3}, "SPECTRA 0001"
            Slot = 0051
            ERROR = 0xE0008212 (E_CHG_INVALID_ELEMENT_ADDRESS)

 

Library 2 of the Hardware Library partitioning was never Inventoried after the hardware change.  Backup Exec was un ware of the hardware configuration change and thus resulted in the jobs going into a queued status looking for slots that no longer existed in the library.

 

 

 

 


Solution



 

Perform a Fully Inventory the robotic libraries after reconfiguring Robotic Library Hardware partitions.

 

 NOTE: Under certian circumstances the Backup Exec database may need to be reviewed by Backup Exec support in order to resolve the issue.

 

 

Symantec Corporation has acknowledged that the above-mentioned issue is present in the current version(s) of the product(s) mentioned at the end of this article. Symantec Corporation is committed to product quality and satisfied customers.
Symantec Corporation currently plans to address this issue by way of a patch or hotfix to the current version of the software. Please be sure to refer back to this document periodically as any changes to the status of the issue will be reflected here. A link to the patch or hotfix download will be added to this document when it becomes available. Please note that Symantec Corporation reserves the right to remove any fix from the targeted release if it does not pass quality assurance tests.  Symantec's plans are subject to change and any action taken by you based on the above information or your reliance upon the above information is made at your own risk.

 

 


Supplemental Materials

SourceETrack
Value2402231
Description

 

NDMP Backup Jobs are sitting in queued status when attempting to mount a scratch volume.



Article URL http://www.symantec.com/docs/TECH162081


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