Some restore selection may not show files to restore. Re-cataloging the media fails with ODBC alerts and An error occurred while retrieving catalog information.
| Article:TECH162746 | | | Created: 2011-06-20 | | | Updated: 2011-07-05 | | | Article URL http://www.symantec.com/docs/TECH162746 |
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Problem
After a successful backup job some restore selections my not show file history or files to restore with a message "No Selections exist for this resource". This may happen if the backup job was an append job and many appends to the same media or media family has taken place. Additionally the restore selection sets displays a negative Backup Set Number (FIGURE 1).
(FIGURE 1)

Error
0xe0000904 - An error occurred while retrieving catalog information.
Final error category: Backup Media Errors
ODBC access error. Possible lost connection to database or unsuccessful access to catalog index in the database.
Environment
Backup Exec for Windows 12.5
Backup Exec 2010 R1, R2, and R3
Cause
This issue occurs because the Backup Set Number or Image number contains a "negative value".
The following Application Log Event appear when attempting to catalog any media in the set.
Application Log Errors:
(Backup Exec 12.5)
The description for Event ID ( 34326 ) in Source ( Backup Exec CatErrorHandler Server ) could not be found. It contains the following insertion string(s): .
Catalog index database
[Microsoft][ODBC SQL Server Driver]Numeric value out of range cat_RecordSet::Open()
r:\corsica\2213r\becat\segodbc\seg_odbc.cpp(2436)
{CALL DeleteCatImageByImageNumberMediaFamilyGuid ( ?, ?, ?) }
(Backup Exec 2010 R3)
The description for Event ID ( 34326 ) in Source ( Backup Exec CatErrorHandler Server ) could not be found. It contains the following insertion string(s): .
Catalog index database
[Microsoft][ODBC Driver Manager] Function sequence error cat_RecordSet::GetRecordCount()
e:\nicobar\5204r\becat\segodbc\seg_odbc.cpp(4015)
SELECT distinct CatMedia.*, ImageObjectView.FragmentState FROM CatMedia, ImageObjectView WHERE CatMedia.MediaFamilyGuid = ImageObjectView.MediaFamilyGuid AND CatMedia.MediaNumber = ImageObjectView.MediaNumber AND ImageObjectView.ImageNumber = ? AND CatMedia.MediaFamilyGuid = ? AND CatMedia.Status & ? = 0
Solution
WORKAROUND:
Use media sets to limit the appendable period of the media and configure jobs to “append to media, overwrite if no appendable media is available.” The recommendation is to configure the appendable period so that Backup Exec can switch to overwrite once a week or another set time period.
NOTE: If data needs to be restored please contact Symantec Technical support. A supported hotfix has been made available for this issue in Backup Exec 2010 R3. Please contact Symantec Technical Support to obtain this fix. This hotfix has not yet gone through any extensive Q&A testing. Consequently, if you are not adversely affected by this problem and have a satisfactory temporary workaround in place, we recommend that you wait for the public release of this hotfix.
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|
| Source | UMI |
| Value | V-79-57344-2308 |
| Description | 0xe0000904 - An error occurred while retrieving catalog information. Final error category: Backup Media Errors |
| Source | Error Code |
| Value | 0xe0000904 |
| Description | 0xe0000904 - An error occurred while retrieving catalog information. Final error category: Backup Media Errors |
| Source | Event ID |
| Value | 34326 |
| Description | Access to catalog index (Catalog index database) failed. |
| Source | UMI |
| Value | V-79-57344-2304 |
| Description | Final error: 0xe0000900 - The requested media is not listed in the media index and could not be mounted. To add the media's catalog information to the disk-based catalogs, run an inventory operation on the media and resubmit the Catalog operation |
| Source | Event ID |
| Value | 34338 |
| Description |
ODBC access error. Possible lost connection to database or unsuccessful access to catalog index in the database |
| Source | Event ID |
| Value | 34326 |
| Description |
The description for Event ID ( 34326 ) in Source ( Backup Exec CatErrorHandler Server ) could not be found. It contains the following insertion string(s): . Catalog index database [Microsoft][ODBC Driver Manager] Function sequence error cat_RecordSet::GetRecordCount() e:\nicobar\5204r\becat\segodbc\seg_odbc.cpp(4015) SELECT distinct CatMedia.*, ImageObjectView.FragmentState FROM CatMedia, ImageObjectView WHERE CatMedia.MediaFamilyGuid = ImageObjectView.MediaFamilyGuid AND CatMedia.MediaNumber = ImageObjectView.MediaNumber AND ImageObjectView.ImageNumber = ? AND CatMedia.MediaFamilyGuid = ? AND CatMedia.Status & ? = 0 |
| Source | Event ID |
| Value | 4326 |
| Description |
The description for Event ID ( 34326 ) in Source ( Backup Exec CatErrorHandler Server ) could not be found. It contains the following insertion string(s): . Catalog index database [Microsoft][ODBC SQL Server Driver]Numeric value out of range cat_RecordSet::Open() r:\corsica\2213r\becat\segodbc\seg_odbc.cpp(2436) {CALL DeleteCatImageByImageNumberMediaFamilyGuid ( ?, ?, ?) } |
| Source | Event ID |
| Value | 34338 |
| Description |
Backup Exec Alert: Catalog Error (Server: ) ODBC access error. Possible lost connection to database or unsuccessful access to catalog index in the database. |
| Source | ETrack |
| Value | 2413855 |
| Description | CATALOG: Unable to restore or catalog data ODBC Error Function sequence error |
Article URL http://www.symantec.com/docs/TECH162746
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