Upgrading the 5000/5020 Appliance to 1.3.0.1 may fail during installation. This issue is resolved in the 1.3.0.1B release.
| Article:TECH163000 | | | Created: 2011-06-22 | | | Updated: 2011-07-06 | | | Article URL http://www.symantec.com/docs/TECH163000 |
Problem
A pre-installation check was omitted from the NetBackup 5000 and 5020 Appliance installer included in the 1.3.0.1 update. If this check is not performed, a condition which prevents successful installation may not be detected and corrected. This can lead to a failure during installation, forcing a rollback of the Appliance.
Error
During installation, messages similar to the following may be displayed:
+ Upgrading to NBU50x0_1.3.0.1
+ Extracting installer components...
+ Stopping the PureDisk services on all nodes...
+ Copying new code (version NBU50x0_1.3.0.1) to all nodes...
+ Re-setting necessary file permissions
Setting permissions on filesystem ... Done
+ Updating SPA configuration with changes for NBU50x0_1.3.0.1.
++ Checking if PureDisk DataBase (pddb) is running
+++ Starting pddb
+++ Starting Memory Cache Daemon
++ Checking if PureDisk DataBase (pddb) is running
+++ Dumping DB tables for rollback purposes
++ Setting PDDO replication concurrency
++ Add new configuration file parameters
!! An unexpected ERROR occured during the upgrade !!
Your Storage Pool can be in an inconsistent state now!
Please contact Symantec Support team and provide them with
the content of '/var/log/puredisk/upgrade/NBU50x0_1.3.0.1/<date>_<time>-main.log'.
!! Upgrade aborted !!
Messages similar to the following may be found in the upgrade logs:
shared.exceptionhandler.2023
severity: 6
server: 1298000000
source: SPA-CLI_Component
description:
[2]pg_query(): Query failed: ERROR: duplicate key violates unique constraint "configfiletemplateline_pkey"
*** End ***
ERROR with exitcode = 1
!! An unexpected ERROR occured during the upgrade !!
Your Storage Pool can be in an inconsistent state now!
Please contact Symantec Support team and provide them with
the content of '/var/log/puredisk/upgrade/NBU50x0_1.3.0.1/<date>_<time>-main.log'.
!! Upgrade aborted !!
Environment
What is Affected:
This issue affects NetBackup 5000 & 5020 Appliances when upgrading to 1.3.0.1.
Initial installations of 1.3.0.1 are NOT affected.
Cause
This failure can only occur on Appliances where hardware email notifications have been configured.
The conditions leading to the "duplicate key" error described above should be checked for prior to beginning an upgrade. This check was not performed in the 1.3.0.1 installer.
The 1.3.0.1B installer DOES contain this check and, if the condition is discovered, steps are taken to resolve the conflict prior to the upgrade. This allows the upgrade to succeed.
Solution
The 1.3.0.1B release (available now using the links in the "Related Articles" section) contains the formal resolution to this issue and may be used to upgrade NetBackup Appliances. The 1.3.0.1 release is no longer available from the support site.
Note: If an upgrade to 1.3.0.1 has already been performed and succeeded, there is no need to apply the 1.3.0.1B release as they are identical. Only the installation process is different.
If an upgrade to 1.3.0.1 has been attempted and the failure above is experienced, please contact Symantec technical support for assistance in rolling back the upgrade and applying 1.3.0.1B.
Best Practices:
Symantec strongly recommends the following best practices:
1. Always perform a full DR backup prior to making any changes to your environment.
2. Always make sure that your environment is running the latest version and patch level.
3. Perform periodic "test" restores.
4. Subscribe to technical articles.
How to Subscribe to Email Notification:
Directly to this Article:
Subscribe to this article by clicking on the Subscribe via email link on this page to receive notification when this article is updated with Release Information.
Software Alerts:
If you have not received this TechNote from the Symantec Email Notification Service as a Software Alert, you may subscribe via email and/or RSS using the links provided at the following page:
http://www.symantec.com/business/support/index?page=content&key=58991&channel=ALERTS
|
|
| Source | ETrack |
| Value | 2417617 |
| Description | configfiletemplateline table id value duplicating issue |
Related Articles
Article URL http://www.symantec.com/docs/TECH163000
Terms of use for this information are found in Legal Notices









Thank you.