DeployAnywhere causing errors with image deployment

Article:TECH163477  |  Created: 2011-06-28  |  Updated: 2011-06-29  |  Article URL http://www.symantec.com/docs/TECH163477
Article Type
Technical Solution


Environment

Problem



DeployAnywhere causing errors with image deployment


Error



Retargeting has been cancelled because some critical drivers are missing


Environment



Deployment Solution 7.1


Cause



A critical driver, i.e. either a mass storage or network card driver, required by the installation is not contained in the DeployAnywhere database


Solution



To identify the missing driver(s):

  1. From WinPE, map a drive to the deployment share of the relevant task server e.g. "net use W: \\%Taskserver%\Deployment /user:[domain\username] password"
  2. Run the command "W:\Task Handler\ghost\DeployAnywhere.exe" /eval /target=c:\Windows /ddb="W:\Task Handler\DriversDB" (N.B. earlier versions than DS7.1 replace DeployAnywhere.exe with GhDplyAw32.exe)
  3. Check the file .\Task Handler\ghost\DeployAnywhere.txt has the Data Modified attribute updated to the current date/time
  4. Identify missing drivers from the DeployAnywhere.txt file
  5. If further information is required to identify the missing drivers, run msinfo32 to create a .nfo file e.g. "msinfo32 /nfo C:\TEMP\SYSSUM.NFO /categories +all"
  6. Identify the correct driver by ensuring its .inf file contains matching PNP_Device_ID to that in the DeployAnywhere.txt file
  7. Import the driver into DeployAnywhere (ref: HOWTO10872)
  8. If the task is run from a Site Server, ensure the Site Server has received the replicated driver by comparing .\Deployment\Task Handler\DriversDB\[new driver folder] for both NS and Site Server



Article URL http://www.symantec.com/docs/TECH163477


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