Hotfix for Symantec Enterprise Vault (EV) for File System Archiving 9.0.2, Build 1061, Event ID 6992 appears stating that the EV Cache location is full while actually there is space available

Article:TECH163875  |  Created: 2011-07-04  |  Updated: 2011-07-04  |  Article URL http://www.symantec.com/docs/TECH163875
Article Type
Technical Solution


Issue



Which version of Symantec Enterprise Vault (tm) can this hotfix be applied?
This hotfix can only be applied to the following versions of Enterprise Vault for:

Enterprise Vault for Microsoft Exchange 9.0.2, Build 1061
 


Error



Event ID: 6992 Error writing to cache location. | This is usually caused by lack of disk space.


Environment



Enterprise for File System Archiving working with pass-through mode or EMC Celerra.


Cause



This problems appears when there are two or more requests for the same file or segment of a file in parallel causing a race condition. The second and subsequent attemps fail to copy the file on the EV Cache location and you get an event id 6992.


Solution



What issue(s) does this hotfix resolve?
 Event ID 6992 appears stating that the EV Cache location is full while actually there is space available and might eventually cause memory corruption issues.


Which files does this hotfix replace? 

File Name File Version
StorageOnlineOpns.exe 9.0.2.1108


How to Install this hotfix:

On each Enterprise Vault Server which is to have the hotfix applied:
1. Stop all Enterprise Vault services on the target EV server.
2. Create a backup of the file 'StorageOnlineOpns.exe' present in the Enterprise Vault Installation Directory on the server (which, by default, is C:\Program Files (x86)\Enterprise Vault).
3. Copy the file 'StorageOnlineOpns.exe', packaged in this hotfix, into this EV installation directory, thus replacing the original file.
4. Restart all Enterprise Vault services on the EV server.

How to Uninstall this hotfix:
On each Enterprise Vault Server which is to have the hotfix uninstalled:
1. Stop all Enterprise Vault services on the target EV server.
2. Delete the 'StorageOnlineOpns.exe' present in the Enterprise Vault Installation Directory on the server (which, by default, is C:\Program Files (x86)\Enterprise Vault).
3. Copy the backup of the file 'StorageOnlineOpns.exe'  which you saved during the hotfix install into this EV installation directory, thus replacing the hotfix'ed file with the original.
4. Restart all Enterprise Vault services on the EV server.


Attachments

Attachment filename: EV 9.0.2 Hotfix - ETrack 2293938.zip
EV 9.0.2 Hotfix - ETrack 2293938.zip (309 kBytes)

Supplemental Materials

SourceETrack
Value2293938
Description

Race condition in byterange cache writes causes StorageOnlineOpns stack memory corruption



Article URL http://www.symantec.com/docs/TECH163875


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