Backup Exec selection list hangs when attempting to establish an SSL trust with a remote server.

Article:TECH164446  |  Created: 2011-07-12  |  Updated: 2012-07-26  |  Article URL http://www.symantec.com/docs/TECH164446
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Article Type
Technical Solution

Product(s)

Problem



Backup Exec Admin Console goes into a "Not Responding" state after attempting to establish a trust with a remote server.

A connection request is sent from the media server and received by the remote, but the connection open reply is not received by the media server from the remote.

This causes the hang in the UI.


Error



Media Server debug - beremote log:

[6720]   [ndmp\ndmpcomm]      - ndmpConnectEx : Control
Connection information: A connection was established between end-points
10.x.x.x:7407 and 10.x.x.x:10000.
[6720]   [ndmp\ndmpclient]    - NDMP version 3 connection CONNECTED

Media Server SGMON log with beserver selected :

BESERVER: [03/09/12 16:17:04] [4276]     12 Djm: pMMSFeature is installed, setting mmsUsable TRUE.
BESERVER: [03/09/12 16:17:04] [4276]     12 Djm: pCASOFeature is null, casoUsable set to FALSE.

Remote Server debug - beremote log:

[6976]   [ndmp\ndmpcomm]      - ndmpRun: Control connection
accepted : connection established between end-points 10.x.x.x:10000 and
10.x.x.x:7407
[6976]   [ndmp\ndmpcomm]      - ndmpCreateConnection
[6380]   [ndmp\ndmpcomm]      - ndmpdConnectionHandler: received
connection(1212).
[6380]   [ndmp\ndmpcomm]      - ndmpSendRequest: message:0x502
[6380]   [ndmp\ndmpcomm]      - ndmp_writeit: len:40
[6380]   [ndmp\ndmpcomm]      - sent          seq#: 1 msg: 0x502
[6380]   [ndmp\ndmpcomm]      - ndmpProcessRequests
[6380]   [ndmp\ndmpcomm]      - ndmp_process_messages:
reply_expected:FALSE
[6380]   [ndmp\ndmpcomm]      - ndmp_recv_msg
[6380]   [ndmp\ndmpcomm]      - ndmp_readit: len:4000
[6380]   [ndmp\ndmpcomm]      - ndmp_process_messages:
processing message 0x108
[6380]   [ndmp\ndmpcomm]      - ndmpdConfigGetServerInfo:
[6380]   [ndmp\ndmpcomm]      - ndmpSendReply: message:0x108
[6380]   [ndmp\ndmpcomm]      - ndmp_writeit: len:108
[6380]   [ndmp\ndmpcomm]      - ndmpFreeMessage: message:0x108
[6380]   [ndmp\ndmpcomm]      - ndmp_process_messages: no more
messages in stream buffer
[6380]   [ndmp\ndmpcomm]      - ndmpProcessRequests
[6380]   [ndmp\ndmpcomm]      - ndmp_process_messages:
reply_expected:FALSE
[6380]   [ndmp\ndmpcomm]      - ndmp_recv_msg
[6380]   [ndmp\ndmpcomm]      - ndmp_readit: len:4000
[6380]   [ndmp\ndmpcomm]      - ndmp_process_messages:
processing message 0x108
[6380]   [ndmp\ndmpcomm]      - ndmpdConfigGetServerInfo:
[6380]   [ndmp\ndmpcomm]      - ndmpSendReply: message:0x108
[6380]   [ndmp\ndmpcomm]      - ndmp_writeit: len:108
[6380]   [ndmp\ndmpcomm]      - ndmpFreeMessage: message:0x108
[6380]   [ndmp\ndmpcomm]      - ndmp_process_messages: no more
messages in stream buffer
[6380]   [ndmp\ndmpcomm]      - ndmpProcessRequests
[6380]   [ndmp\ndmpcomm]      - ndmp_process_messages:
reply_expected:FALSE
[6380]   [ndmp\ndmpcomm]      - ndmp_recv_msg
[6380]   [ndmp\ndmpcomm]      - ndmp_readit: len:4000
[6380]   [ndmp\ndmpcomm]      - ndmp_process_messages:
processing message 0x900
[6380]   [ndmp\ndmpcomm]      - ndmpdConnectOpen:
protocol_version:3.
[6380]   [ndmp\ndmpsrvr]      - sslOpen() : Opening SSL for:
E05DF5CF
[6380]   [ndmp\ndmpsrvr]      - sslOpen(): certinfo = E05DEEF7 ;
sslConn = E05CA9A7

This shows a connection attempt was received and is open but no reply received by the media server.


Cause



Cause 1: This can be caused by a misconfigured Managed Media Server role in which NO Central Administration Server (CAS) has been created.

Cause 2: CAS was not properly defined during install of the Managed Media Server option.

Example: Usage of loopback address for the CAS name during install rather than an actual, resolvable, remote server name.


Solution



Workaround for Cause 1: Remove the Managed Media Server Option.

Workaround for Cause 2: Reinstall the Managed Media Server Option with the correct CAS machine name.

 

Symantec Corporation has acknowledged that the above-mentioned issue is present in the current version(s) of the product(s) mentioned at the end of this article. Symantec Corporation is committed to product quality and satisfied customers.
This issue is currently being considered by Symantec Corporation to be addressed in the next major revision of the product.  There are no plans to address this issue by way of a patch or hotfix in the current or previous versions of the software at the present time.  Please note that Symantec Corporation reserves the right to remove any fix from the targeted release if it does not pass quality assurance tests or introduces new risks to overall code stability.  Symantec's plans are subject to change and any action taken by you based on the above information or your reliance upon the above information is made at your own risk.
 
Please be sure to refer back to this document periodically as any changes to the status of the issue will be reflected here.
Please contact your Symantec Sales representative or the Symantec Sales group for upgrade information including upgrade eligibility to the release containing the resolution for this issue.  For information on how to contact Symantec Sales, please see   http://www.symantec.com

 


Supplemental Materials

SourceETrack
Value2431297
Description

BE UI hangs when attempting to establish an SSL trust with a remote server.




Article URL http://www.symantec.com/docs/TECH164446


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