SF 5.1SP1 didn't discover all disks that belongs to EMC CLARiiON CX4 array.

Article:TECH164604  |  Created: 2011-07-13  |  Updated: 2012-07-28  |  Article URL http://www.symantec.com/docs/TECH164604
Article Type
Technical Solution


Environment

Issue



This is a new install of our product and then the following error gave out while executing the vxdisk scandisks.
-cx600_claim_device: On HP-UX 11.31, EMC CLARiiON is supported only in ALUA mode. Please configure device /dev/rdsk/c11t5d4 in ALUA mode
Moreover, No disk information at output of the vxdisk list command.
 


Environment



Storage Foundation(SF) 5.1 SP1

HP-UX 11.31

EMC CLARiiON CX4 960.


Cause



Output of the vxcheckasl against one correspondent device:


vxcheckasl libvxCLARiiON.sl /dev/rdsk/c113t5d0
       libvxCLARiiON.sl:vendor_info()
       VID                                    : DGC
       PID                                    :
       ATYPE                                  : ALUA
       ANAME                                  : EMC_CLARiiON
       NR_DEVICE                              : Y
       ASL_VERSION                            : vm-5.1.100-rev-1
       libvxCLARiiON.key()
       ASL Name                               : libvxCLARiiON.sl
       Feature Needed                         : 95
       VxVM Version Needed                    : 51
       Device                                 : /dev/rdsk/c113t5d0
       Vendor Identification                  : DGC
       Product Identification                 : CX4-960WDR5
       Revision Number                        : HP03
       Serial Number                          : Ch2 CONTROLL >>>
cx600_claim_device: On HP-UX 11.31, EMC CLARiiON is supported only in ALUA mode. Please configure device /dev/rdsk/c113t5d0 in ALUA mode  >>>
       libvxCLARiiON.sl:claim_device()        : SKIPPED  >>>
 

The vxcheckasl command appreard SKIPS against the EMC CLARiiON device and SCSI inquiry for a correspondent DGC device did not show a serial number.

And, we could see that the vxconfigd debug log showed we found the LUNs and due to ASL not claiming, then disconnect the array. So, No device discovered in VxVM layer.

After checking with this customer direclty, we found out that the Initiator type of the array set to HP No Auto Trespass.


Solution



 

 

Suggested Initiator type in the array set to CLARiiON Open then, rescaneed all device, eventually VxVM discovered all devices well.

Need to check whether the following 4 conditions are meet to use with the supported our product:

- Minimum firmware: FLARE 28 (CX4)

- Initiator type: CLARiiON Open

- Failover Mode: 4

- DMP Failover mode: ALUA




Article URL http://www.symantec.com/docs/TECH164604


Terms of use for this information are found in Legal Notices