User getting access denied when restoring an item, shortcut content is displayed.
| Article:TECH164628 | | | Created: 2011-07-14 | | | Updated: 2012-08-26 | | | Article URL http://www.symantec.com/docs/TECH164628 |
Problem
A user trying to restore an item from the vault. The item changes to pending item, then changes back to an archived item icon.
When the user opens the item, and the following message appears;
"Your account does not have access to the vault containing this item. Try using the same logon details you would to log on to the Exchange Server.
Alternatively you may ask your Help Desk to grant you access to the Vault. Do you want to log on to Enterprise Vault under another account?"
Error
9434615 09:10:13.111 [4236] (StorageOnlineOpns) <3620> EV:H {CClientIdentity::CheckAccess(vSIDS)} (Exit) Status: [Access is denied. (0x80070005)]
9434616 09:10:13.111 [4236] (StorageOnlineOpns) <3620> EV:H {CClientIdentity::CheckAccess} (Exit) Status: [Access denied (0xc0041801)]
9434617 09:10:13.111 [4236] (StorageOnlineOpns) <3620> EV:H {CStorageOnline::CheckCallersVaultAccess} (Exit) Status: [Access denied (0xc0041801)]
9434618 09:10:13.111 [4236] (StorageOnlineOpns) <3620> EV:L {CStore::~CStore} (Entry)
9434619 09:10:13.111 [4236] (StorageOnlineOpns) <3620> EV:L {CStore::CloseVault} (Entry)
9434620 09:10:13.111 [4236] (StorageOnlineOpns) <3620> EV:L {CVault::~CVault} (Entry)
9434621 09:10:13.111 [4236] (StorageOnlineOpns) <3620> EV:H {CVault::~CVault} (Exit) Status: [Exception occurred. (0x80020009)]
9434622 09:10:13.111 [4236] (StorageOnlineOpns) <3620> EV:L {CExclusiveUseThread::EndExclusiveUse} (Entry)
9434623 09:10:13.111 [4236] (StorageOnlineOpns) <3620> EV:H {CExclusiveUseThread::EndExclusiveUse} (Exit) Status: [Exception occurred. (0x80020009)]
9434624 09:10:13.111 [4236] (StorageOnlineOpns) <3620> EV:H {CStore::CloseVault} (Exit) Status: [Exception occurred. (0x80020009)]
9434625 09:10:13.111 [4236] (StorageOnlineOpns) <3620> EV:L {CStore::CloseIndexerNotifier} (Entry)
9434626 09:10:13.111 [4236] (StorageOnlineOpns) <3620> EV:H {CStore::CloseIndexerNotifier} (Exit) Status: [Exception occurred. (0x80020009)]
9434627 09:10:13.111 [4236] (StorageOnlineOpns) <3620> EV:L {CStore::CloseDatabase} (Entry)
9434628 09:10:13.111 [4236] (StorageOnlineOpns) <3620> EV:M SingletonRegistry: US '0X34A3E90TransactionContext'
9434629 09:10:13.111 [4236] (StorageOnlineOpns) <3620> EV:M SingletonRegistry: US '0X34A3E901'
9434630 09:10:13.111 [4236] (StorageOnlineOpns) <3620> EV:M SingletonRegistry: US '0X34A3E90'
9434631 09:10:13.111 [4236] (StorageOnlineOpns) <3620> EV:H {CStore::CloseDatabase} (Exit) Status: [Exception occurred. (0x80020009)]
9434632 09:10:13.111 [4236] (StorageOnlineOpns) <3620> EV:H {CStore::~CStore} (Exit) Status: [Exception occurred. (0x80020009)]
9434633 09:10:13.111 [4236] (StorageOnlineOpns) <3620> EV:L {CStorageSession::~CStorageSession} (Entry)
9434634 09:10:13.111 [4236] (StorageOnlineOpns) <3620> EV:H {CStorageSession::~CStorageSession} (Exit) Status: [Exception occurred. (0x80020009)]
9434635 09:10:13.111 [4236] (StorageOnlineOpns) <3620> EV:H CStorageOnline::LoadSaveset _com_error exception. hr=Access denied (0xc0041801)
9434636 09:10:13.111 [4236] (StorageOnlineOpns) <3620> EV:H {CStorageOnline::LoadSaveset} (Exit) Status: [Access denied (0xc0041801)]
9434637 09:10:13.111 [4236] (StorageOnlineOpns) <3620> EV:H {CStorageOnline::GetOnlineAttachment} (Exit) Status: [Access denied (0xc0041801)]Environment
SERVER: Server OS: Windows 2003 Standard SP2 EV Version: Ev 9.0.2 Number of EV Servers: 3 Storage Type/Version/Mode: EMC Clarion Outlook Version: 2003 CA Version: /EV Binaries Version: NA DA Version: /EV Binaries Version: 9.0.2 Exchange Version: 2010 SP1 Update 3 SharePoint Version: MOSS /WSS: None SQL Server Version: 2008 SQL Cluster info: EV none SQL yes Virtual Environment: ESXi 4.0 update 1 Anti Virus: McAffee (Exclusions)
Cause
Reason for this behavior is that a shortcutted item was forwarded or copied into an email without restoring the item first. If the user that the shortcut is forwarded to does not have at least read-access to the original senders Archive the item cannot be opened and an access denied error will appear.
Solution
a. Click the problem item, hold down shift+ctrl keys and click one of the EV buttons.
b. Select Vault Information bottom left of the pop up window.
c. In this info box, scroll down to selected item properties, then copy the archive ID associated with the item.
d. On the EV Server, hold down SHIFT+CTRL keys and right-click "Archives" in the console. On the contextual menu select "Find Archive or Folder"
e. Paste the archive ID copied from the selected item properties then click find.
f. Note the Archive name that is listed.
g. Get the properties of the listed archive and verify the client trying to restore the item has access to the vaulted items with "Read" access. If not then add the user with "Read" access to this account.
g. Close and reopen Outlook then try to restore the item again.
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Article URL http://www.symantec.com/docs/TECH164628
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