Unable to open the Symantec Endpoint Protection client interface after migrating to 12.1 on Windows 7 64-bit

Article:TECH164707  |  Created: 2011-07-15  |  Updated: 2012-01-16  |  Article URL http://www.symantec.com/docs/TECH164707
Article Type
Technical Solution

Product(s)

Environment

Issue



The SEP 12.1 client malfunctions after a migration from SEP 11 RU6 MP2 (or similar).  After the migration Symantec Settings Manager service remains in Starting state. 


Error



Trying to start the Symantec Endpoint Protection service fails with the following error:

Symantec Endpoint Protection cannot open because some Symantec Services are stopped. Restart the Symantec services, and then open Symantec Endpoint Protection.

 

After rebooting the computer the Symantec Settings Manager service is removed but Symantec Endpoint Protection service will not start. The error reported in the event viewer is:

"The Symantec Endpoint Protection service terminated with service-specific error %%-1"

 

Also after rebooting twice, an attempt to repair the Symantec Endpoint Protection 12.1 installation resulted in the following error:

Error 1406. Could not write value Working Set Threshold to key \SOFTWARE\Symantec Endpoint Protection\{DC2F6DF9-3CBC-4CAE-BCC2-466375BF8768}\Common Client\WorkingSetGarbageCollector\SmcService. Verify that you have sufficient access to that key, or contact your support personnel.

 

 


Environment



This behavior has only observed under Windows 7 x64 with specific configuration. The issue only happens if there is an Application and Device Control (ADC) policy that activates the setting "Protect client files and registry keys" under Application Control.


Cause



This issue happens due to conflict during the migration procedure created by having the option "Protect client files and registry keys" in the Application and Device Control policy.

 


Solution



This issue has been addressed in the Symantec Endpoint Protection 12.1 RU1 release, which can be obtained from Fileconnect.

PLEASE NOTE: Deploying a SEP 12.1 RU1 client over a SEP 12.1 RTM client that is experiencing this issue will not remedy the issue.  You must uninstall the SEP 12.1 client via add/remove programs or Cleanwipe (in my case we had to use cleanwipe)

When migrating to the previous version 12.1 RTM, it is possible to workaround this issue by disabling the option to "Protect client files and registry keys" before migrating the SEP 11 client to SEP 12.1. This option should remain disabled to all 12.1.




Article URL http://www.symantec.com/docs/TECH164707


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