After upgrade to 5.1SP1, one node could not join the cluster. LLT startup failed with "cluster id already being used" error.

Article:TECH164898  |  Created: 2011-07-18  |  Updated: 2012-08-28  |  Article URL http://www.symantec.com/docs/TECH164898
Article Type
Technical Solution


Environment

Issue



In a 2 node cluster, after upgrade to 5.1SP1, one node (nodeB) fails to join the cluster. LLT startup fails with error. The MAC address printed is the MAC address of one of the LLT links of its cluster partner (nodeA).


Error



[root:/etc/init.d]# ./llt.rc start
  Loading LLT Driver...
  Starting LLT...
  LLT lltconfig ERROR V-14-2-15245 cluster id 110 is already being used by nid 0 and has the address - XX:XX:XX:YY:YY:YY
  LLT lltconfig ERROR V-14-2-15664 LLT could not configure any link


Environment



Storage Foundation For  Oracle Real Application Cluster(SFROARAC) 5.1 SP1.

AIX 6.1

 


Cause



In VCS 5.1SP1, duplicate cluster-id detection feature was introduced in LLT startup. The MAC address shown in the above error message is one of the private links of other node in cluster. To confirm this, the tcpdump was gathered for LLT links on both the nodes when LLT was started. In this case, 2 extra bytes were received for one of the LLT links which caused this bug to be hit.


Solution



It was suspected that the checksum on the NIC adapter puts the extra bytes on the packet. The LLT bug id for this issue is: 2439895 and is fixed in VCS 5.1SP1RP2. sort.symantec.com/patch/detail/5503




Article URL http://www.symantec.com/docs/TECH164898


Terms of use for this information are found in Legal Notices