Attempting to select Lotus Domino resources for backup may hang indefinitely

Article:TECH164926  |  Created: 2011-07-19  |  Updated: 2011-07-19  |  Article URL http://www.symantec.com/docs/TECH164926
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Article Type
Technical Solution

Product(s)

Environment

Issue



When creating or running a backup of Lotus Domino databases, the selection or backup may hang indefinitely.  During creation of a backup, this will occur when attempting to expand the 'Lotus Domino Databases' icon or the 'Databases on...' volume selections beneath it. 


Cause



Once in a hung state, the selections will never expand and the Backup Exec Remote Agent will need to be stopped and restarted on the Lotus Domino server in order to exit the hung state.  This issue is caused by multiple versions of some Lotus Domino DLL being present.  When initiating the connection with Domino server, the Backup Exec Remote Agent uses the BELNAPI.EXE process to create this connection.  In creating the connection, if BELNAPI.EXE finds an older version of a Domino DLL the connection will not be fully initialized and the process will hang.  Perform a search for multiple copies of the following Lotus Domino DLLs on the Lotus Domino server:

NDGTS.DLL
JS32.DLL
NLSCCSTR.DLL
NXMLPROC.DLL
NNOTES.DLL
NSTRINGS.DLL


Solution



If multiple copies of any of the above DLLs are present, within Windows Explorer you can right-click and get the properties of the duplicates.  The later version of the DLL should be present in the folder where the Domino binaries are located and will be a version equal to the Version and Fix Pack level of Domino server running.  Most likely the older version will be in some other folder, possibly the Domino Data folder.  In cases we have seen this issue occur, we have simply renamed the older version of DLL located outside of the Domino binaries folder to resolve the issue.  Consult IBM support or Lotus Domino documentation if you have any questions related to any impact renaming these DLLs could have.

Note that in some cases after the older DLL has been removed the Domino selection/backup process may still hang.  In this situation, it is recommended to add the Domino binaries location to the Windows search path environment variable.  The Path environment variable can be accessed and edited by going through Computer | Properties | Advanced System Settings | Environment Variables.  Locate the 'Path' system variable and click edit.  The Lotus Domino binaries file location can be added after the %SystemRoot% or Windows locations.  Consult Microsoft documentation with questions regarding editing the Path.





Article URL http://www.symantec.com/docs/TECH164926


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