Inventory policies are missing schedules and may be uneditable.

Article:TECH165335  |  Created: 2011-07-22  |  Updated: 2011-10-05  |  Article URL http://www.symantec.com/docs/TECH165335
Article Type
Technical Solution


Environment

Problem



"Custom Schedules" are missing their data.
Related possible issues include:

  • Errors editing the policy configuration
  • Cannot clone a policy

Error



A.logs may report: Unable to generate policy XML for item <GUID>


Cause



It is likely that during the install or the upgrade the configuration files became damaged.


Solution



Repair and reconfigure the current solution.
For Inventory Solution 7.1 SP1 right click and "Repair":

  • altiris_inventorysolution_7_1
  • altiris_inventorysolution_7_1_sp1_tech162729_hf1_x64
    • Note: the file name may be different depending on the version installed.  Best Practice is to repair the lastest build.

Run "aexconfig /configure " with the following configuration files:

  • Inventory.config
  • Inventory _7_1_SP1_tech162729

Restart the console.

In some cases, disabling then re-enabling the policies is needed to reset them after the repair and reconfigure.




Article URL http://www.symantec.com/docs/TECH165335


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