Error Installing/Adding/Configuring Asset Cubes

Article:TECH165715  |  Created: 2011-07-27  |  Updated: 2011-07-27  |  Article URL http://www.symantec.com/docs/TECH165715
Article Type
Technical Solution


Issue



This has revealed itself in various ways. Duplicate entries and/or a lack of ability to add asset cubes to a configured Management console being the most common


Error



 Exception: Item has already been added. Key in Dictionary: 'Assets' Key being added. 'Assets'.


Environment



v7.1 SP1


Cause



Error in SIMS product listing incorrectly had Asset Management Pack still listed when these cubes were also contained in CSMP Pack, causing duplicate entries in the Database. Because the database believes that the AMS pack is installed, it tries to load the AMS assembly which then causes errors.

 

 


Solution



  • Manually run an unconfigure on the AMS product using AexConfig
  • Manually uninstall the AMS msi using msiexec /x  with the SKIPAIM=1 switch
  • Restart the Altiris Service
  • Restart IIS

NOTE:

in order to run the AexConfig command, a product guid is needed. One way to get this information is to look for a folder in the following path: <x>:\Program Files\Altiris\ITAnalyticsAMP\config. Within that folder is a file called ITAnalyticsAMP.config. Search for an entry such as <productGuid> xxxxxxxxxxxxxxxxxxx </productGuid>, the xxxxxxxxxxxxxx representing the appropriate guid..

For additional information, please also see KB# TECH161853. The following forum entry may also provide some additional insight

http://www.symantec.com/connect/forums/exception-item-has-already-been-added-key-dictionary-assets-key-being-added-assets

 




Article URL http://www.symantec.com/docs/TECH165715


Terms of use for this information are found in Legal Notices