VMware Agent (AVVI) backup fails with One or more required subsystems failed to initialize Error: 16053

Article:TECH165786  |  Created: 2011-07-28  |  Updated: 2014-04-24  |  Article URL http://www.symantec.com/docs/TECH165786
Article Type
Technical Solution

Product(s)

Subject

Issue



A VMware backup job using Backup Exec fails reporting  the error messages provided below. Additionally if debugging is enabled of the beremote process on the media server then an entry containing 'One or more required subsystems failed to initialize' Error: '16053' will be found  

 


Error



Unable to open a disk of the virtual machine.
VixDiskLib_Open() reported the error: One or more required subsystems failed to initialize

and

0xe0009585 - Unable to open a disk of the virtual machine.
Final error category: Resource Errors


 


Cause



 There are two known causes for this issue:

Cause 1: Invalid versions of required files for VMware backups are located directly in \Program Files\Symantec\Backup Exec (created by manual steps during the presvious history of the server)

Cause 2: 3rd Party Software uses common files required for VMware backups but has placed their own versions higher in the search path of the operating system

 


Solution



Cause 1:

  1. Make a note of the file names located in \Program Files\Symantec\Backup Exec\VMware\vixdisklib\bin and \Program Files\Symantec\Backup Exec\VMware\vixdisklib\plugins
  2. Stop the Backup Exec services on the media server
  3. Remove any of the file names noted in Step 1 from \Program Files\Symantec\Backup Exec
  4. Restart the BE services and test your VMware backups - if this solves the condition then Cause 1 applies to the condition and Symantec consider this solved as the files should not be located there.
  5. If the previous steps did not solve the issue then apply the hotfix described below.

 

Cause 2:

 A hotfix is now available for this issue in the current version(s) of the product(s) mentioned in this article. Refer to the Hotfix link under Related Documents at the end of this article to obtain the hotfix needed to resolve the issue.

 Backup Exec 2012 Rev 1798 Service Pack 3 (TECH205351).

 Backup Exec 2010 R3 Rev 5204 Service Pack 4 (TECH208828).

 


Supplemental Materials

SourceETrack
Value2481094
Description

AVVI: One or more required subsystems failed to initialize' Error: '16053' that is sometimes linked with a BEREMOTE Crash


SourceETrack
Value2558850
Description

AVVI: One or more required subsystems failed to initialize' Error: '16053' seen when conflicting products install VMware related DLL's in the search paths




Article URL http://www.symantec.com/docs/TECH165786


Terms of use for this information are found in Legal Notices