Recovery Solution 7.1.3919 - WBFR not correctly restores folder which name has at least two spaces, for example “My favorite folder”

Article:TECH165934  |  Created: 2011-07-29  |  Updated: 2011-08-18  |  Article URL http://www.symantec.com/docs/TECH165934
Article Type
Technical Solution


Issue



WBFR not correctly restores folder which name has at least two spaces, for example “My favorite folder”


Environment



Applies to Recovery Solution version 7.1.3919 (RS 7.1)


Cause



Spaces in the name of the folder are not translated properly


Solution



Point fix is attached to this article. It contains the following files:

 RecoveredFiles.zip -  file that will be replaced on the RS Server to fix WBFR problem
 readme.txt  -  pointfix installation instructions
 SubInAcl.exe  -  Microsoft (R) utility used to restore security attributes over patched file
 install.bat  -  batch file that performs pointfix installation
 uninstall.bat  -  batch file that performs pointfix uninstallation

Note:
 RecoveredFiles.zip is not an archive that contains a fixed binary, it is a file that must be replaced on RS server. You don't have to open or copy this file manually. It will be replaced by batch command file.

To apply pointfix on RS Server performs following steps:

1) Place extracted files on the RS server that must be patched (any folder can be used for that purpose)
2) Execute install.bat under local admin account.

The install.bat file will output execution log to console. We recommend running it in a console mode (CMD.exe) to review the output. It also returns 0 in success and 1 in failure case.
The install.bat will create a "backup" folder in its execution directory and palce an original RecoveredFiles.zip there.
To perform pointfix uninstall - execute uninstall.bat under local admin accout: it will replace RecoveredFiles.zip with one stored in "backup" folder.

Example of successful execution can be seen below:

c:\temp>install.bat


 ******************** Reading security information ...
SUCCESS: The file (or folder): "C:\Program Files (x86)\Altiris\Recovery Solution
\Server\WBFR" now owned by user "MIKE71\Administrator".
 *** Changing security information ...
 *** Replacing security descriptor on
 C:\Program Files (x86)\Altiris\Recovery Solution\Server\WBFR
Are you sure (Y/N)?processed dir: C:\Program Files (x86)\Altiris\Recovery Soluti
on\Server\WBFR
SUCCESS: The file (or folder): "C:\Program Files (x86)\Altiris\Recovery Solution
\Server\WBFR\RecoveredFiles.Zip" now owned by user "MIKE71\Administrator".
 *** Replacing security descriptor on
 C:\Program Files (x86)\Altiris\Recovery Solution\Server\WBFR\RecoveredFiles.Zip
Are you sure (Y/N)?processed file: C:\Program Files (x86)\Altiris\Recovery Solut
ion\Server\WBFR\RecoveredFiles.zip
 *** Patching file ...***
Backup old file
ECHO is off.
C:\Program Files (x86)\Altiris\Recovery Solution\Server\WBFR\RecoveredFiles.zip
1 File(s) copied
        1 file(s) copied.
 *** Reverting security information ...
 *** Replacing security descriptor on
 C:\Program Files (x86)\Altiris\Recovery Solution\Server\WBFR\RecoveredFiles.Zip
Are you sure (Y/N)?processed file: C:\Program Files (x86)\Altiris\Recovery Solution\Server\WBFR\RecoveredFiles.zip 
*** Replacing security descriptor on
 C:\Program Files (x86)\Altiris\Recovery Solution\Server\WBFR
Are you sure (Y/N)?processed dir: C:\Program Files (x86)\Altiris\Recovery Solution\Server\WBFR
C:\Program Files (x86)\Altiris\Recovery Solution\Server\WBFR\RecoveredFiles.Zip
: nt authority\system is the new owner
C:\Program Files (x86)\Altiris\Recovery Solution\Server\WBFR\RecoveredFiles.Zip
: 1 change(s)
Elapsed Time: 00 00:00:00
Done:        1, Modified        1, Failed        0, Syntax errors        0
Last Done  : C:\Program Files (x86)\Altiris\Recovery Solution\Server\WBFR\RecoveredFiles.Zip
C:\Program Files (x86)\Altiris\Recovery Solution\Server\WBFR : nt authority\system is the new owner
C:\Program Files (x86)\Altiris\Recovery Solution\Server\WBFR : 1 change(s)
Elapsed Time: 00 00:00:00
Done:        1, Modified        1, Failed        0, Syntax errors        0
Last Done  : C:\Program Files (x86)\Altiris\Recovery Solution\Server\WBFR
 ***************************************
 ***      Patching Succeeded         ***
 ***************************************

IMPORTANT:
Batch file will work just fine on platforms like Windows 2003, 2008 and Windows Seven. On Windows XP the batch will fail as one of the commands used (takeown) is not supported by Windows XP. If you are running RS Server on Windows XP platform you will need to replace RecoveredFiles.zip manually according to steps below:

1) Go to "c:\Program Files(x86)\Altiris\Recovery Solution\Server\WBFR" folder
2) Open properties for RecoveredFiles.zip file.
3) Navigate to "security" tab.
4) Click "advanced" button.
5) Navigate to "Owner" tab.
6) Take an ownership over RecoveredFiles.zip file - change "owner" from "system" to currently logged on user.
7) Press "OK".
8) Now, in "Security" tab, press "Edit" and grant full access rights to RecoveredFiles.zip file for currently logged on user.
9) Replace original RecoveredFiles.zip file with one that contains fix.
10) Open file properties again, and change security by removing currently logged on used from access list.
From this point fix is installed, no any actions like IIS restart etc. are required.

About SubInACL.exe

More information about the utility that is used during installation can be found here:
http://www.microsoft.com/download/en/details.aspx?amp;amp;DisplayLang=en&id=23510

 


Attachments

TECH165934.ZIP (107 kBytes)

Supplemental Materials

SourceETrack
Value2481195


Article URL http://www.symantec.com/docs/TECH165934


Terms of use for this information are found in Legal Notices