Sharepoint 2010 backup fails with 'Unable to query the Team database meta' when Microsoft Office Web Apps Service Pack 1 is present

Article:TECH166772  |  Created: 2011-08-09  |  Updated: 2013-09-30  |  Article URL http://www.symantec.com/docs/TECH166772
NOTE: If you are experiencing this particular known issue, we recommend that you Subscribe to receive email notification each time this article is updated. Subscribers will be the first to learn about any releases, status changes, workarounds or decisions made.
Article Type
Technical Solution


Environment

Issue



There are many causes to the error 0xe000031a.  To determine the root cause, the failing job must be debugged. 

How to debug SharePoint jobs: http://www.symantec.com/docs/TECH37467


Error



      Job log:

Backup- PowerPointServiceApp Proxy\Proxy (SWHQSPDB01T\00819b3a-5175-4d0b-a487-a6eb9ec3b5e7)V-79-57344-794 - Error: Unable to query the Team database meta-data.

Backup- PowerPointServiceApp\Metadata (SWHQSPDB01T\c1b067cd-a245-414d-a425-e6b58dd4b3a4)V-79-57344-794 - Error: Unable to query the Team database meta-data.

      From the SPSWrapper log:

Error  exception in running cmd Get-SPServiceApplicationProxy -identity 00819b3a-5175-4d0b-a487-a6eb9ec3b5e7 Exception is Exception getting "EnableClipart": "The given key was not present in the dictionary."

Error  exception in running cmd Get-SPServiceApplication -identity c1b067cd-a245-414d-a425-e6b58dd4b3a4 Exception is Exception getting "EnableViewingOpenDocumentFormats": "The given key was not present in the dictionary."


Cause



When Sharepoint 2010 has the Microsoft Office Web Applications add-on installed with Service Pack 1, doing a Sharepoint agent backup will show a failure on the Powerpoint service app metadata and service app proxy.  Service Pack 1 for the Office Web App package adds some additional fields to the metadata for these items that the Backup Exec Remote Agent isn't aware of.


Solution



Workaround:

Deselect the Powerpoint service app metadata and Powerpoint service app proxy from backup.

 

Symantec Corporation has acknowledged that the above-mentioned issue is present in the current version(s) of the product(s) mentioned in this article. Symantec Corporation is committed to product quality and satisfied customers.
 
There are currently no plans to address this issue by way of a patch or hotfix in the current or previous versions of the software at the present time. This issue may be resolved in a future major revision of the software at a later time. However, this particular issue is not currently scheduled for any release.  If you feel this issue has a direct business impact for you and your continued use of the product, please contact your Symantec Sales representative or the Symantec Sales group to discuss these concerns.  For information on how to contact Symantec Sales, please see    http://www.symantec.com 
 

 
Please be sure to refer back to this document periodically as any changes to the status of the issue will be reflected here.

Supplemental Materials

SourceETrack
Value2493404
Description

SPSV4: PPT Service app backup fails when Office Web App SP1 is applied


SourceUMI
ValueV-79-57344-794
Description

 V-79-57344-794  Unable to query the team database metadata


SourceError Code
Value 0xe000031a
Description

  0xe000031a - Unable to query the team database metadata.




Article URL http://www.symantec.com/docs/TECH166772


Terms of use for this information are found in Legal Notices