DLO backup of Outlook PST files is slow during the "Copying local" phase of the backup job

Article:TECH167369  |  Created: 2011-08-17  |  Updated: 2013-02-04  |  Article URL http://www.symantec.com/docs/TECH167369
Article Type
Technical Solution


Environment

Issue



When DLO performs a backup of an Outlook PST file, it must first stage the snapshot of the PST to the Local User Data Folder (LUDF), then it copies the file to the Network User Data Folder (NUDF) .  During this first stage, the "Status" column in the Symantec NetBackup Desktop Agent window reads "Copying local (x%)".

Sometimes the "Copying local" phase can be very slow.

 


Error



 No Error - slow performance


Cause



There are several reasons why the "Copying local" phase can be slow.

1. The PST file is very large.  The snapshot still occurs on the entire PST file, even if it is only doing a "Message level incremental".
2. The local AntiVirus application may be slowing down the process.  Try disabling AntiVirus and observe the performance of the next backup job.
3. DLO might be doing disk throttling.   DLO monitors the LogicalDisk Performance Counter called "Current Disk Queue Length".  If the queue length exceeds 2 (default value of 2) DLO introduces a sleep mechanism during the "Copying local" phase of the backup jobs.  This is to prevent DLO from consuming disk cycles which other applications might need.


Solution



To find out if DLO is introducing a sleep mechanism, enable DLO Agent logging and capture the slow backup job in the log.
 
To enable DLO Agent Logging:
1. Launch the DLO Agent GUI
2. Select Tools > Support > Enable Verbose Logging
3. Restart the DLO Agent (don't just minimize it and maximize it)
 
Once a slow backup has been captured, locate the newly created DLOClient.log file:
 
The DLOClient.log will be located here:  
* On Windows7: 
C:\Users\<userName>\AppData\Local\Symantec\DLO\.settings
 
* On XP: 
C:\Documents and Settings\<userName>\Local Settings\Application Data\Symantec\DLO\.settings
 
Look for lines like the following:
diskthrottle.cpp( 228 ) Read queue: 8.73956, sleeping for 2000ms
diskthrottle.cpp( 228 ) Read queue: 4.50836, sleeping for 1254ms
diskthrottle.cpp( 228 ) Read queue: 11.5639, sleeping for 2000ms
diskthrottle.cpp( 228 ) Read queue: 3.54665, sleeping for 773ms
diskthrottle.cpp( 228 ) Read queue: 2.85208, sleeping for 426ms
diskthrottle.cpp( 228 ) Read queue: 14.9235, sleeping for 2000ms
diskthrottle.cpp( 228 ) Read queue: 5.72238, sleeping for 1861ms
diskthrottle.cpp( 228 ) Read queue: 6.50065, sleeping for 2000ms
 
In the above example, it can be observed that DLO is introducing a sleep mechanism to prevent over-throttling of the physical disk.
 
The average of the sum of the queue length above is 6.625.  Rounding up = 7.
 
If logs suggest the performance delays are associated with disk throttling (as seen above) and you have determined that it is alright for DLO to consume additional disk resources, these registry adjustments will increase the threshold at which DLO engages disk throttling:
 
NOTE: DLO will divide the specified registry value by 10 - so take the observed average queue length (as seen above) and multiply by 10 to determine which value to implement in the registry.
 
1. Open regedit
2. Navigate into HKLM\Software\Symantec\DLO\3.0\Client
3. Create a new DWORD value named DiskQueueLimit
4. Give it a value of 70 decimal
5. Navigate into HKCU\Software\Symantec\DLO\3.0\Client
6. Create a new DWORD value named  DiskQueueLimit
7. Give it a value of 70 decimal
8. Restart the DLO Desktop Agent (don't just minimize and maximize it)
 
Symantec DLO 7.x the registry keys are slightly different.
 
1. Open regedit
2. Navigate into HKLM\Software\Symantec\Symantec DLO\Client
3. Create a new DWORD value named DiskQueueLimit
4. Give it a value of 70 decimal
5. Navigate into HKCU\Software\Symantec\Symantec DLO\Client
6. Create a new DWORD value named  DiskQueueLimit
7. Give it a value of 70 decimal
8. Restart the DLO Desktop Agent (don't just minimize and maximize it)
 
For Windows 7 64bit systems the registry key to be modified is also different:
 
1. Open regedit
2. Navigate into HKLM\Software\Wow6432Node\Symantec\Symantec DLO\Client
3. Create a new DWORD value named DiskQueueLimit
4. Give it a value of 70 decimal
5. Restart the DLO Desktop Agent (don't just minimize and maximize it)
 
 
NOTE: The value of 70 was obtained by calculating the average read queue length during a slow backup event and multiplying by 10..  The value of 70 may not necessarily apply to all desktop environments.  Follow the logging example above to determine the average queue length experienced on the problematic host, and apply the observed adjusted average to the DiskQueueLimit registry key.



Article URL http://www.symantec.com/docs/TECH167369


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