Trying to uninstall Dell Client Solution or Dell Management Console results in errors, or, having them installed results in resource errors
| Article:TECH167462 | | | Created: 2011-08-18 | | | Updated: 2012-04-17 | | | Article URL http://www.symantec.com/docs/TECH167462 |
Problem
Having Dell Client Solution/Dell Client Manager (DCS/DCM) or Dell Management Console (DMC) installed results in issues in the Symantec Management Platform (SMP) 7.0 console or is otherwise desired to be uninstalled. Trying to do so, however, results in issues. This prevents the original issues from being resolved, such as issues when trying to edit a computer resource, Dell-related errors occur.
Error
The following are known issues that occur after Dell solutions are removed from the SMP 7.0 environment. These are primarily seen with DMC but can also be seen when using DCS/DCM.
- Unable to edit resources such as computers, which results in Dell-related errors.
- NSE files from previously existing Dell Computer resources couldn’t be processed by NS, as result, the basic inventory from the mentioned resources couldn’t be added to NS database. “Unable to process the file...” and “Altiris.NS.Exceptions.AeXException: Failure in save for Resource item. [Object reference not set to an instance of an object.]” errors were seen in NS log every time previous Dell Computer resource tried to send basic inventory.
- “Unable to retrieve ItemAction” errors were logged to NS log if right-click menu was opened for any resource in NS console.
- Unable to import any new software in Software Management.
- Packages are missing in rollout policies if upgrade was performed after Dell solutions uninstall.
Note: While these issues are primarily seen in SMP 7.0, it is possible that these problems can be carried over into SMP 7.1 if the database is migrated.
Cause
The uninstall process for DCS/DCM and DMC and other Dell solutions is not properly recognized by the SMP 7.0 server. The failure of several solutions to properly recognize that these components have been uninstalled then leads to other issues in the SMP console.
Solution
An internal only article is available to clean up these issues in SMP 7.0. In general, these cannot be used in SMP 7.1. Please contact Technical Support for assistance in deploying this fix to SMP 7.0.
Related Article
Dell Solutions and the Symantec Management Console
http://www.symantec.com/business/support/index?page=content&id=HOWTO59488
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Article URL http://www.symantec.com/docs/TECH167462
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