Symantec Critical System Protection (SCSP) agents go off offline due to the transaction log in the database being full

Article:TECH167859  |  Created: 2011-08-23  |  Updated: 2012-07-28  |  Article URL http://www.symantec.com/docs/TECH167859
Article Type
Technical Solution


Environment

Issue



Large number of Symantec Critical System Protection (SCSP) agents go off offline. This includes both Windows and Unix agents. This issue occurs on older and newer versions of the SCSP agents.


Error



A red circle icon appears in the management console GUI and the agent is not reporting events to the management server.

sis-agent.log
[ERROR] [SQL:9002] The transaction log for database 'SYMSCSP' is full. To find out why space in the log cannot be reused, see the log_reuse_wait_desc column in sys.databases
java.sql.BatchUpdateException: The transaction log for database 'SYMSCSP' is full. To find out why space in the log cannot be reused, see the log_reuse_wait_desc column in sys.databases

sis-console.log
ERROR] [LoginHandler:524] [SQL:9002] The transaction log for database 'SYMSCSP' is full. To find out why space in the log cannot be reused, see the log_reuse_wait_desc column in sys.databases
java.sql.BatchUpdateException: The transaction log for database 'SYMSCSP' is full. To find out why space in the log cannot be reused, see the log_reuse_wait_desc column in sys.databases


Environment



Environment:
• SCSP 5.2.6.178
• SCSP 5.2.6.183
• Windows(R) Server 2003 Standard x64 Edition
• Total Physical Memory: 2,047 MB
• Failover enabled


Cause



It appears that the issue is related to the transaction log in the database being full. Because of it being full no new data can be inserted or updated. This is causing the agents to go offline and not allowing the agent to report events to the manager.


Solution



Steps to backup the database and shrink the transaction log:

First back up the database (steps 1-5)
1. Use ‘sa’ username to login to SQL Server Database using SQL Server Management Studio.
2. Expand Databases, and select SCSPDB database.
3. Right click the database and select Tasks->Backup
4. Select Backup Type as Full
5. Click on Add and select a backup destination on an external disk.
• This will back up the entire database and might take a while to execute.
• Please ensure that you have sufficient amount of disk space on external drive.
• Press OK.
How to shrink the transaction log (steps 6-13)
6. Right-click the instance, and then click Properties, which opens the Database Properties dialog box.
7. In the Select a Page pane, click Options.
8. The current recovery model is displayed in the Recovery model list box.
9. Change Recovery model from Full to Simple. Press OK
10. Right-click the SCSPDB database, and then select ->Tasks->Shrink->Files
11. Change File type from Data to Log. Ensure that
• Filename is changed to scsplog
• File location ends with SCSPDBlog.ldf
12. Set Shrink action to Release Unused Space. Press OK
• The above steps should shrink the transaction log. Verify the transaction log file size on disk.
13. Repeat steps 6 to 9 and set recovery model back from Simple to Full.

On another note, we strongly recommend that the memory on the servers is increased to at least 4GB each. This is not causing a real problem however you will find that the systems will perform better if this is done.

Once you have resolved the issue, It is recommended that you add this to your database maintnance plan.




Article URL http://www.symantec.com/docs/TECH167859


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