Due to orphaned users, the SQL database of SEPM failed to move to the new server .

Article:TECH167988  |  Created: 2011-08-24  |  Updated: 2011-10-31  |  Article URL http://www.symantec.com/docs/TECH167988
Article Type
Technical Solution


Subject

Issue



After the customer  moves the database files from the old SQL Server to a new one,  the SEPM server cannot connect the new database in the management server wizard .


Environment



SQL server 2005

Windows 2003


Cause



A login is used for user authentication and a database user account is used for database access and permissions validation. Logins are associated to users by the security identifier (SID). A login is required for access to the SQL Server server. This login must be associated to a SQL Server database user. You use the user account to control activities performed in the database. If no user account exists in a database for a specific login, the user that is using that login cannot access the database even though the user may be able to connect to the SQL Server server.
When a database is restored to a different server it contains a set of users and permissions but there may not be any corresponding logins or the logins may not be associated with the same users. This condition is known as having "orphaned users."


Solution



Relink the server login  with the database user by script in the new SQL server. And then the orphaned user issue has been resolved.

For more details, please refer to  http://support.microsoft.com/kb/274188





Article URL http://www.symantec.com/docs/TECH167988


Terms of use for this information are found in Legal Notices