Unable to push/deploy the PGP Support Package for BlackBerry

Article:TECH168177  |  Created: 2011-08-26  |  Updated: 2011-09-08  |  Article URL http://www.symantec.com/docs/TECH168177
Article Type
Technical Solution


Subject

Issue



Even though it is possible to deploy the PGP Support Package Over The Air (OTA) via the BlackBerry Enterprise Server (BES), after configuring the package on the BES, you may encounter an error:


Error



Missing dependency
The application net.rim.blackberry.secureemail.pgp version Unknown is missing.


Cause



This is a known issue where the BlackBerry Administration Service could not resolve dependencies on a SMIME_lib specified in BlackBerry.alx.   This issue also affects the PGP Support Package for BlackBerry.  This is outlined in a KB article on the RIM site:

http://btsc.webapps.blackberry.com/btsc/search.do?cmd=displayKC&docType=kc&externalId=KB22623


Solution



A workaround is to remove the "requires" tag in the package ALX:

<requires id="net.rim.blackberry.secureemail.pgp"/>

Like S/MIME, the PGP_lib  is always contained within the BlackBerry Core Application Libraries.

 





Article URL http://www.symantec.com/docs/TECH168177


Terms of use for this information are found in Legal Notices