Live Update Policy fails with status 77 and free space requirements

Article:TECH168280  |  Created: 2011-08-28  |  Updated: 2011-08-28  |  Article URL http://www.symantec.com/docs/TECH168280
Article Type
Technical Solution


Issue



When Live Update policy runs to upgrade a client it requires space in /tmp.  If this space if not sufficient,  then you will see 'nbliveup Exit: EXIT STATUS 77'   in the live update log.  


Error



In the liveupdate.log  you will see messages like "The file being retrieved exceeded the maximum allowed size of
734,003,200 bytes"  and also "nbliveup Exit: EXIT STATUS 77"

 


Cause



The free space required in /tmp is not enough to download the upgrade software.

 


Solution



The allowed size of the LiveUpdate package is controlled by the following entries in the LiveUpdate configuration file on the client   

/usr/openv/netbackup/nblu.conf:

maxPackageContentSize=
maxPackageSize=

The maxPackageContentSize= and maxPackageSize= values are recorded in bytes with the default limit of 700 MB in NetBackup 7.0.

maxPackageContentSize=734003200
maxPackageSize=734003200

 In NetBackup 7.1 GA these values were increased to 2GB

maxPackageContentSize=2147483647
maxPackageSize=2147483647

In order to determine the amount of space required in /tmp, you need to multiply the size of the zip bundle by 3 and round up the result.
For example: the size of Linux Client patch (1307982071jtun_nb_clt_7.1.0.1_linux.zip)  is 1.1 G. Therefore around 4G available in /tmp is required.

Also you can change the download location by modifying the following paramter in /usr/openv/netbackup/nblu.conf

workdir=/tmp

Change this location to a directory which has enough space as per the above information.

 

 

 

 




Article URL http://www.symantec.com/docs/TECH168280


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