Export Reports Error Message "Out of Memory" When IM Conversation Contains Thousands of Messages

Article:TECH168536  |  Created: 2011-08-31  |  Updated: 2011-10-19  |  Article URL http://www.symantec.com/docs/TECH168536
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Article Type
Technical Solution

Product(s)

Issue



Export job fails. 

 


Error



  • The Windows Application Event log shows the following error message:

   Log Name:      Application
      Source:         IMLogicAdminService
      Date:          3/15/2011 10:31:33 AM
      Event ID:      113
      Task Category: None
      Level:         Error
      Keywords:      Classic
      User:          BLACKOPS-SIMM\jesse_von_dietsch
      Computer:      jvdw2k8r2im8417.blackops-simm.com
      Description:
      Error 0x8007000e processing input file C:\IMManagerExports\EVExport2\IML4.xml.

      Description: Out of memory.
      . Failed conversation was moved to C:\IMManagerExports\EVExport2\errors\Error-IML4.xml

  • Export history shows the following error message:

Internal Error 0x8007000e processing input file C:\IMManagerExports\EVExport2\IML4.xml.

      Description: Out of memory.

To view the export history perform the following steps from the IM Manager Administration Console:

1. Click on the Administration tab.
2. Click on Configuration|Export menu item.
3. Click on the History icon for the export job.

Conditions

  • There are IM conversations that contain many thousands of messages. 

Typically this issue can happen when an IM conversations contains over ten thousand (10,000) messages.  Run the following SQL query against the IM Manager database.  Before running the query replace the date ranges with ones appropriate to your environment:

SELECT     CONVERT(varchar(100), message_date, 1) AS day, session_guid, COUNT(id) AS numberofmessages, SUM(DATALENGTH(content))
                      AS totalcharactersizeofconversation
FROM         messages
WHERE     (message_date BETWEEN '5/24/2011' AND '6/10/2011')
GROUP BY CONVERT(varchar(100), message_date, 1), session_guid
having count(id) > 10000
ORDER BY COUNT(id) DESC

 

The conversations with the highest number of messages are returned first.  The following is an example:

    03/07/06    CHAT-569596-195832-1141774369182079-2006-03-07    152037    1272010
    01/24/06    105264628954270397-2006-01-24                                       18630    168498
  

In this example above the first conversation contain over 150,000 messages.  It is likely that conversation is causing the issue. 

 

 

 


Cause



The export function is keeping the entire conversation in memory.  When memory runs out this issue occurs.


Solution



This issue has been resolved with the release of IM Manager 8.4.18.


Please upgrade to the latest version to resolve this issue.

 Workaround

  • Remove the affected conversation from the IM Manager database.

Conversations with over ten thousand messages are unlikely to be "real" IM conversations.  In most instances these are conversations caused by this issue: Database Size Grows Exponentially When Thousands of Registration Notification Messases Logged.  If so removing the IM conversations from the IM Manager database may be an option.

1. Run the SQL query above to determine the affected conversation IDs.
2. Run the following SQL against the IM Manager database to remove the conversation.  Replace the session ID with the appropriate one returned from the SQL query.

Delete from messages where session_guid = '<session_guid>'

For example if the SQL query returns this data:

    03/07/06    CHAT-569596-195832-1141774369182079-2006-03-07    152037    1272010

following then run this SQL query:

Delete from messages where session_guid = 'CHAT-569596-195832-1141774369182079-2006-03-07'

 


Supplemental Materials

SourceETrack
Value2116810

SourceETrack
Value2244313



Article URL http://www.symantec.com/docs/TECH168536


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