Symantec Backup Exec™ Management Plug-in for VMware® - Version 2

Article:TECH169148  |  Created: 2011-09-08  |  Updated: 2011-11-09  |  Article URL http://www.symantec.com/docs/TECH169148
Article Type
Technical Solution


Issue



 

This plug-in is for use with Backup Exec 2010 R3 with the Agent for VMware Virtual Infrastructure installed and configured to backup virtual machines.  This plug-in will allow VMware administrators to view and perform limited management tasks for backup operations on selected virtual systems from the vSphere Client management console.

Through the use of the vSphere Client management console this plug-in provides the backup status of virtual machines and details of past and future backups.

 


Environment



Any system capable of running the VMware vSphere client version 4.0.

Supported platforms include the following:

  • Backup Exec 2010 R3
  • ApplicationHA version 6.0 (required for Virtual Machine Auto Recovery feature)
  • VMware vCenter Server version 4.0 and later
  • VMware vSphere Client version 4.0 and later
  • VMware ESX version 4.0 and later
  • VMware Workstation 7.0 and later (required for Virtual Machine Validator feature)
  • Microsoft .Net Framework 3.5 SP1 or above
  • Adobe Acrobat (any version)

 What’s new in this version of the Backup Exec Management Plug-in for VMware?

Support for VMware vSphere 5.0

Ensures that vSphere 5.0 environments are protected and supports the newest features in Sphere 5.0 such as Virtual Machine Format Version 8, vCenter 5.0, vSphere Storage DRS, Storage vMotion and Datastore clusters.

 

Virtual Machine Validator

Enables VMware and Backup Exec administrators to easily validate the recoverability of full virtual machine backup via the vSphere client console. The Virtual Machine Validator is part of the Backup Exec Management plug-in for VMware and tests full virtual machine backups by booting the virtual machine backup in a separate and specialized recovery environment, thereby ensuring backups are recoverable every time. Recoverability reports are available to instantly view the results of these tests for every virtual machine.

Note:  VMware Workstation 7.x, Microsoft .Net Framework 3.5 SP1 or above and vSphere 4.x or greater are required for Virtual Machine Validator. Please refer to the Backup Exec Management Plug-in for VMware Administrators Guide for complete details

What kind of backups can be verified?
·         AVVI full GRT backups to B2D or de-duplication storage folder B2D or de-duplication storage folder.

 What kind of backups cannot be verified?

·         Backups to tape are not supported.

·         Backup sets from set copy jobs are not supported.

·         AVVI backups to Symantec Pure Disk OST device cannot be verified.

 

Backup Exec Auto Recovery for VMware

Integration of the Backup Exec Management Plug-in 2.0 for VMware and Symantec’s ApplicationHA 6.0 solution will enable Backup Exec to automatically restore a failed VM in order to recover lost application services once Symantec ApplicationHA has exhausted the steps available to remediate the failure.

Symantec ApplicationHA 6.0 GA build is available on Fileconnect.  The documentation is available for reference on SORT, DocCentral and the Symantec website. 

 


Solution



Attached are the installation instructions and file(s) needed for installation.

For all systems download the following compressed file in .zip format:

Symantec Backup Exec Management Plug-in for VMware.zip

Unzip the files and perform the installation according to the instructions in the attached ReadMe.txt file. 


Frequently Asked Questions (FAQs)

1.  Does this plug-in only work with VMware vCenter?

 No. You can directly connect to an ESX host and see whether the virtual machines are protected or you can connect to the vCenter host and view protection status for groups of virtual machines.

2. Is there a way I can save the media server credentials from the “Symantec Backup Exec” plug-in tab?

 No. The plug-in does not save credentials due to security reasons. Similarly, the vSphere client console prohibits you from saving user credentials from a vCenter or ESX host.

3. Why do some VMs show as being unprotected even though I can see them as being backed up in Backup Exec?

 From the plug-in, you must connect to the VMware machine (vCenter or ESX host) the same way you select VMs in Backup Exec. If you use the NetBIOS name of an ESX host when selecting its VMs, then you must connect to that ESX host from the vSphere client using the same NetBIOS name. If you use the IP address or FQDN to connect in vSphere, the plug-in will not be able to associate the protected resources. See the ‘Monitoring View’ section of the User’s Guide for more detail.

 


Attachments

Symantec Backup Exec Management Plug-in for VMware v2.0.266
Symantec Backup Exec Management Plug-in for VMware.zip (40.9 MBytes)
Symantec Backup Exec Management Plug-in for VMware v2.0.266 Readme.txt file
ReadMe.txt (12 kBytes)





Article URL http://www.symantec.com/docs/TECH169148


Terms of use for this information are found in Legal Notices