PGP Desktop - Windows installer has encountered a problem and needs to close...

Article:TECH169553  |  Created: 2011-09-14  |  Updated: 2012-03-19  |  Article URL http://www.symantec.com/docs/TECH169553
Article Type
Technical Solution



Subject

Issue



 When installing PGP Desktop, you receive the following Windows Installer errors:

 Windows installer has encountered a problem and needs to close. The installation terminated prematurely.

 

 


Error



"Windows installer has encountered a problem and needs to close"

"The installation terminated prematurely"

 


Environment



Windows XP


Cause



Some Microsoft Windows Installer hotfixes may have error handlers that do not ignore any errors and fail the installation process if any errors are encountered.

One such hotfix is Microsoft Windows Installer hotfix KB981669. If Microsoft hotfix KB981669 is installed, the hotfix will not ignore any errors and will cause the PGP Desktop installation to fail.
For more information, see the following Microsoft Support article:

support.microsoft.com/kb/981669

 


Solution



Uninstall Microsoft Installer KB981669 from the computer and then reboot the system. Restart the PGP Desktop installation.

or

Workaround (without uninstall KB981669)

1. Install ORCA tool from internet (it’s part of Windows installer SDK,
which can be downloaded from MS site).
2. Open the PGP installer  MSI package using ORCA tool (right click .msi
and select ‘Edit with ORCA)
3. Find ‘RemoveExistingProducts’ API from ‘Edit|Find’ option in ORCA
tool. It should be present in ‘InstallExecuteSequence table).
4. Set the value ‘0’ (Zero) in column ‘condition ‘ for a row
of ‘RemoveExistingProducts’.
5. Save the changes.
6. Run the changed msi to install product


Supplemental Materials

SourceETrack
Value2472861



Article URL http://www.symantec.com/docs/TECH169553


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