Error messages in the Notification Server logs showing "Couldn't find underlying policy for resource"

Article:TECH169876  |  Created: 2011-09-19  |  Updated: 2012-03-06  |  Article URL http://www.symantec.com/docs/TECH169876
Article Type
Technical Solution


Issue



Whenever clients check in to the Notification Server to get an updated policy, a warning-level message appears in the logs, explaining it couldn't find the underlying policy for the resource.


Error



The specific message is as follows:

Priority: 2
Process: w3wp (7048)
Module: w3wp.exe
Source: Altiris.Agent.Unix.Policy.UnixAgentInstall.OnBuildClientConfigXml2
Description: Couldn't find underlying policy for resource 22cdc034-0033-4129-ba79-37104f4bb9f2

 


Environment



Symantec Management Platform 7.1 (SP1)


Cause



The problem has been identified with different policies enabled for the computer, including cloned Agent/Plug-in rollout policies.


Solution



If the policy causing the problem is disabled, the warnings will stop showing up in the logs.  As it is sometimes difficult to identify the policy, using the information in KB HOWTO10484 with the computer guid from the logs can help find the problem policy.  When viewing the policy XML in IE, collapse each <policy> tag until one is found that does not collapse.  It will be the policy that has a problem.  Disabling the policy will cause the errors to stop, or if you can find the error with the policy, fix the error.





Article URL http://www.symantec.com/docs/TECH169876


Terms of use for this information are found in Legal Notices