KNOWN ISSUE: Unable to export from a layers 64bit registry hive via its layer properties

Article:TECH170345  |  Created: 2011-09-26  |  Updated: 2011-11-16  |  Article URL http://www.symantec.com/docs/TECH170345
NOTE: If you are experiencing this particular known issue, we recommend that you Subscribe to receive email notification each time this article is updated. Subscribers will be the first to learn about any releases, status changes, workarounds or decisions made.
Article Type
Technical Solution


Environment

Issue



When attempting to export an item from a layers “Name (64-bit)” registry hive, the save action does not save.

This issue has been reproduced using all publicly available 64bit Symantec Workspace Virtualization (SWV) builds (6.3.2046, 2059 & 2065, 6.4.1266 & 1346).

This problem occurs if SWV is cleanly installed as well as if it is upgraded.

This situation happens when using either an existing 64bit layer or with a newly
created 64bit layer.

Steps to reproduce:
1.  Install SWV 6.3.2046 64bit or later on Windows 7 64bit.
2.  After the reboot, either import an already created 64bit layer or create a
new one. 
3.  Deactivate the layer and then open its properties.
4.  Go to its Registry tab.
5.  Either expand a hive that has "(64-bit)" as part of its name and then
choose the Export right-click menu item, or perform that action on the hive
itself.
6.  Choose a location to export to, supply a name and press the Save button.
7.  The save action will not work and refreshing the targeted save location
will confirm this.
8.  Attempt to export from a hive that does not have "(64-bit)" as part of its
name, and you will succeed.


Environment



SWV 6.4.1346 64bit on Windows 7 Enterprise 64bit


Cause



Unfortunately the "EditRegistryPage::GetTreeItemKeyName" code was never updated to
handle the 64-bit registry paths.


Solution



The "EditRegistryPage::GetTreeItemKeyName" code has now been updated to handle 64bit registry paths, and will be included in the upcoming 6.1 Service Pack (SP) 8 release.


Supplemental Materials

SourceETrack
Value2555549
Description

When attempting to export an item from a “Name (64-bit)” registry hive, the save action does not save.



Article URL http://www.symantec.com/docs/TECH170345


Terms of use for this information are found in Legal Notices