Installer shows Error Message "Failed to verify SMSMSE user has mailbox" When Null Parameters for System.Management.Automation.CmdletInvocationException.

Article:TECH171117  |  Created: 2011-10-05  |  Updated: 2014-06-05  |  Article URL http://www.symantec.com/docs/TECH171117
Article Type
Technical Solution


Issue



 

SMSMSE installer is run.  The Service Account information dialog box is displayed.  The SMSMSE service account username and password is entered.  After Next is clicked a dialog box displays the following error messasge:

Failed to verify SMSMSE user has mailbox

After clicking OK the installer stops and does not install SMSMSE.


Error



  • The SMSMSE installer log SMSMSE65_Setup.log shows the following error message:

 

 

 

 

"ExecMonadCmdLet.exe" "C:\Program Files\Microsoft\Exchange Server\V14\bin\exshell.psc1" .\CheckMailBox.ps1 \""symantec\administrator""
fnCheckMailbox: Process Execution  Failed, exit code : 101
DisplayMessageBox

 

 

 

See the following KB on obtaining an installer log: Obtaining detailed installation logging for the installed Symantec Mail Security for Microsoft Exchange product.

  • When ExecMonadCmdLet.exe is run from the command line the following error message is displayed:


ExecMonadCmdLet : Exception : System.Management.Automation.CmdletInvocationException: Value cannot be null.
Parameter name: parameters ---> System.ArgumentNullException: Value cannot be null.
Parameter name: parameters
   at Microsoft.Exchange.Configuration.Tasks.TaskVerboseStringHelper.FormatUserSpecifiedParameters(PropertyBag parameters)
   at Microsoft.Exchange.Configuration.Tasks.Task.LogCmdletIterationEvent()
   at Microsoft.Exchange.Configuration.Tasks.Task.BeginProcessing()
   at System.Management.Automation.Cmdlet.DoBeginProcessing()
   at System.Management.Automation.CommandProcessorBase.DoBegin()
   --- End of inner exception stack trace ---
   at System.Management.Automation.Internal.PipelineProcessor.SynchronousExecuteEnumerate(Object input, Hashtable errorResults, Boolean enumerate)
   at System.Management.Automation.PipelineNode.Execute(Array input, Pipe outputPipe, ArrayList& resultList, ExecutionContext context)
   at System.Management.Automation.StatementListNode.ExecuteStatement(ParseTreeNode statement, Array input, Pipe outputPipe, ArrayList& resultList, ExecutionContext context)

 

Perform the following steps to validate this error message:

1. Run the installer until the error message is displayed.
2. Copy the following files from the directory C:\Users\Administrator\AppData\Local\Temp\{03E91804-3466-4F92-9248-98E506733B8B}:

ExecMonadCmdLet.exe
CheckMailBox.ps1

to the Microsoft Exchange bin directory, typically C:\Program Files\Microsoft\Exchange Server\V14\bin.

NOTE:  The directory {03E91804-3466-4F92-9248-98E506733B8B}  is where the installer extracts the installations files.  This is specified by the TEMP environment variable.  An easy way to locate this is by typing %TEMP% into the windows explorer address bar.

3. Open a command prompt and cd to the Microsoft Exchange bin directory.
4. Run the following command from the command prompt:

 

 

 

 

ExecMonadCmdLet.exe exshell.psc1 .\CheckMailBox.ps1 "<service account name>"

 

 

 

 

 

 

replace <service account name> with the name of the SMSMSE service account.  For example the following is the command to check the user adminuser1 in the domain testdomain:

 

 

 

 

ExecMonadCmdLet.exe exshell.psc1 .\CheckMailBox.ps1 "testdomain\adminuser1"

 

 

 

 

 

 


Cause



The execmonadcmdlet.exe program is unable to use the Exchange Automation Snap-in correctly.


Solution



Symantec is aware of this issue.  This was fixed in version 7.0 and above.

The solution is to upgrade to 7.0.x and above.

Workaround for 32 bit servers:  Use the attached EXE with the SMSMSE installer.

1. Run the SMSMSE installer
2. At the first prompt in the installer save the attached file execmonadcmdlet.exe to the directory %TEMP%\{03E91804-3466-4F92-9248-98E506733B8B}.  This overwrites the existing file.
3. Proceed with the installer.

NOTE:  This hotfix EXE must be used during upgrades and uninstall as well.  Follow the same steps for replacing the standard installer EXE.
 


Attachments

execmonadcmdlet.exe (6 kBytes)

Supplemental Materials

SourceETrack
Value2575222



Article URL http://www.symantec.com/docs/TECH171117


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