Unable to load or create any task/job from the Notification Server Console

Article:TECH172275  |  Created: 2011-10-20  |  Updated: 2011-11-27  |  Article URL http://www.symantec.com/docs/TECH172275
Article Type
Technical Solution


Issue



 After upgrading the Symantec Management Platform to MR4 tasks/jobs cannot be loaded. Creating a task/job is also impossible.


Error



 The error seen in the logs is the following:

 

 

Process: w3wp (4308)

Thread ID: 115

Module: w3wp.exe

Source: Altiris.NS.UI.CoreWebService

Description: Error getting node url: Altiris.NS.Exceptions.AeXException: An unexpected exception has occured during CreateInstance. (Assembely:Altiris.SoftwareManagement, Version=7.0.0.0, Culture=neutral, PublicKeyToken=d516cb311cfb6e4f Type:Altiris.SoftwareManagement.Tasks.DeliverSoftware) ---> System.IO.FileNotFoundException: Could not load file or assembly 'Altiris.TaskManagement, Version=7.1.1800.0, Culture=neutral, PublicKeyToken=99b1e4cc0d03f223' or one of its dependencies. The system cannot find the file specified.

File name: 'Altiris.TaskManagement, Version=7.1.1800.0, Culture=neutral, PublicKeyToken=99b1e4cc0d03f223'

 


Environment



 Notification Server 7.0 SP5 MR4


Cause



 During the upgrade the task management environment was not properly upgraded


Solution



Step 1: 

- From  C:\program files\Altiris\Symantec Installation Manager\Installs\Altiris\ locate the MSI file called altiris_taskmanagement_7_0_doc3480_mr4_x86.msi 

- Make sure your in session 0 on the server

- From a command prompt run the command:

msiexec /i altiris_taskmanagement_7_0_doc3480_mr4_x86.msi skipaim=1

 

Step 2:

- Reconfigure the Task Server solution in order to recreate the missing virtual directories in IIS

- In a command prompt run C:\Program Files\Altiris\Notification Server\bin\AeXConfig.exe /configure C:\Program Files\Altiris\TaskServer Tasks\Config\Task ServerTasks.Config

Step 3:

- Restarted the server

- Open the Notification Server console and try to access or create a task/job: the error should not be seen anymore




Article URL http://www.symantec.com/docs/TECH172275


Terms of use for this information are found in Legal Notices