Searches failing with error "Input string was not in a correct format"
| Article:TECH172565 | | | Created: 2011-10-24 | | | Updated: 2012-04-05 | | | Article URL http://www.symantec.com/docs/TECH172565 |
Problem
Searches can fail if the results need to be written to disk on an Operating System where the decimal separator is not a period.
This will affect types of searches such as:
1. Virtual Vault
2. Compliance Accelerator (CA)
3. Discovery Accelerator (DA)
4. FSAUtility
5. Certain end-user searches that sort by slow-sort fields like author or subject
Error
When the issue is encountered, an Error and a corresponding Warning can be logged into the Enterprise Vault (EV) Event Log:
Type: Error
Event: 7182
Source: Enterprise Vault
Category: Not used
User: N/A
Computer: EVServer.Domain.local
Description:
Index Search failed: Index Search failed: Index: Internal reference: (0xc0041c0e)
Index: 5E3R34C6E8848D4A881D9D3D80E36B6C1110000EVServer.Domain.local/Volume:12
Internal reference: SRCI
Type: Warning
Event: 41315
Source: Enterprise Vault
Category:
User: N/A
Computer: EVServer.Domain.local
Description:
A search failed with error "Input string was not in a correct format.".
Archive: Tech docs
Archive ID: 5E3R34C6E8848D4A881D9D3D80E36B6C1110000EVServer.Domain.local
Index volume ID: 12
User: DOMAIN\VaultAdminAccount
A Dtrace snippet of the EVIndexQueryServer and EVIndexVerifyTask processes will show the following:
(EVIndexQueryServer) <3024> EV-H {INDEXSERVERSEARCHSERVICE.EN_US} Exception: Input string was not in a correct format. Info:Search via HTTP/POST failed. Diag:HRESULT: c0041c0e
(EVIndexVerifyTask) <5480> EV~E Event ID: 7182 Index Search failed: Index Search failed: Index: Internal reference: (0xc0041c0e) |Index: 5E3R34C6E8848D4A881D9D3D80E36B6C1110000EVServer.Domain.local/Volume:12 |Internal reference: SRCI |
Environment
- Operating Systems (OS) where the decimal separator is not a period " . "
Examples of such OS are French, Russian and German where the decimal separator is a comma " , "
- Enterprise Vault 10.0 Base
Cause
This problem affects any search where the 64 bit Indexing Engine writes the results to disk and the regional settings are such that the decimal point separator is not a period.
Solution
This issue has been addressed in the following release:
Enterprise Vault 10.0.1
http://www.symantec.com/docs/TECH147787
Workaround
The workaround is to change the regional number format settings on the Indexing Server to use a period for the decimal separator.
To change the regional number format:
- Navigate to Start --> Control Panel --> "Clock, Language, and Region" --> "Change the date, time, or number format"
- Select "Additional Settings" on the Formats tab.
- Change the "Decimal symbol" value to a period "."
- Save your changes.
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| Source | ETrack |
| Value | 2583086 |
| Description | IQS failing to write search results to disk when regional settings do not use a a period as the floating point separator. |
Related Articles
Article URL http://www.symantec.com/docs/TECH172565
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