Unable to log in Veritas Operations Manager after installation and configuration
| Article:TECH172682 | | | Created: 2011-10-24 | | | Updated: 2011-11-11 | | | Article URL http://www.symantec.com/docs/TECH172682 |
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Problem
After installation and configuration of the Veritas Operations Manager (VOM) Central Server (CS), logging in as root (Unix credentials) resulted in the error below.
Error
V-394-53245-73
Failed to login. User is not authorized.

Environment
Operating System (OS)
Solaris 10
Central Server (CS)
4.0
While this issue was discovered in the environment above, the issue is likely to occur with any version of VOM on any supported Unix OS.
Cause
The GID was set to 1 instead of 0 in /etc/passwd.
# grep root /etc/passwd
root:x:0:1:Super-User:/root:/sbin/sh
# grep root /etc/group
root::0:
other::1:root
For security, VOM requires that the login belong to the group root, Unix defaults to a GID of 0. In this case, root had a GID of 1 and belonged to the group other (but not the group root).
# id
uid=0(root) gid=1(other)
# groups
other bin sys adm uucp mail tty lp nuucp daemon
Solution
The GID in the /etc/passwd file was changed from 1 back to 0 and the root login to the CS worked as expected.
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Article URL http://www.symantec.com/docs/TECH172682
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