SMC service will not start. Error 0x80070102
| Article:TECH173484 | | | Created: 2011-11-02 | | | Updated: 2013-04-25 | | | Article URL http://www.symantec.com/docs/TECH173484 |
Problem
SMC service has been running and starting successfully for sometime, but now suddenly has stopped and won't start.
Cause
The policy files have become corrupt. The following errors appear in the SMC system log:
Solution
The following fix was added in 11.0 RU7 MP1:
SMC.exe fails to start when the policy file (serdef.dat) is corrupt
Fix ID: 2351705
Symptom: SMC.exe will fail to start when the policy file (serdef.dat) is corrupt.
Solution: SMC.exe will now use the backup.dat and server.dat instead of serdef.dat, if serdef.dat cannot be loaded.
The following fix was added in 12.1 RU1:
SMC.exe fails to start when the policy file (serdef.dat) is corrupt
Fix ID: 2359517
Symptom: SMC.exe will fail to start when the policy file (serdef.dat) is corrupt.
Solution: SMC.exe will now use the backup.dat and server.dat instead of serdef.dat, if serdef.dat cannot be loaded.
1. Delete the serdef.dat and possibly the serdef.dat.bak file.
These files are located in
\Program Files\Symantec\Symantec Endpoint Protection\
or
\Program Files(x86)\Symantec\Symantec Endpoint Protection\
2. Start the SMC service.
If the service fails to start, it is likely the server.dat and other policy files are corrupt as well. Reinstall SEP, or replace the .dat files with known good copies from a working SEP client of the same group.
Note: If you are unable to delete the files, you will need to mark them for deletion on reboot using the SysInternals "MoveFile" tool. Additionally, be aware that whatever policy file that is used to replace the original, is what the client will load with.
http://technet.microsoft.com/en-us/sysinternals/bb897556
Manual workaround (if already on 11.0 RU7 MP1 or 12.1 RU1):
In situations where the clients have already been updated to 11.0 RU7 MP1 or 12.1 RU1, this would point to corruption that extends beyond serdef.dat and serdef.dat.bak. Investigate a client and determine if the additional corruption resides in cltdef.dat, cltdef.dat.bak, server.dat, or backup.dat. The only time SMC will fail to start during a policy corruption scenario in 11.0 RU7 MP1 or 12.1 RU1 is if the corruption resides in cltdef.dat and cltdef.dat.bak or serdef.dat, serdef.dat.bak, server.dat, and backup.dat simultaneously. Here are the steps to perform if the corruption resides in cltdef.dat and cltdef.dat.bak:
1. Disable Tamper Protection (if applicable)
2. Stop SMC (smc –stop)
3. Replace the corrupt cltdef.dat and cltdef.dat.bak with known-good copies from another client
4. Start SMC (smc –start)
5. Re-enable Tamper Protection (if applicable)
Note: In 11.0 RU7 MP1 and 12.1 RU1 there is no need to manually replace serdef.dat and serdef.dat.bak.
To manually correct clients that have had their serdef.dat/serdef.dat.bak replaced with one from an incorrect group, make a modification to any policy applied to the group that the client should reside in on the SEPM-side and it will correct the client to reflect the proper group again on the client-side.
Please contact Symantec Technical Support for further assistance if any difficulty is experienced in identifying which policy is or may be corrupt.
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Article URL http://www.symantec.com/docs/TECH173484
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