SMC service will not start. Error 0x80070102

Article:TECH173484  |  Created: 2011-11-02  |  Updated: 2013-09-24  |  Article URL http://www.symantec.com/docs/TECH173484
Article Type
Technical Solution

Product(s)

Environment

Issue



SMC service has been running and starting successfully for sometime, but now suddenly has stopped and won't start.

The following errors appear in the SMC system log:

11/2/2011 11:51:45 AM  Error        Smc   Import config file to data manager failed.

11/2/2011 11:51:45 AM  Error        Smc   Manager cannot load client policy

11/2/2011 11:51:45 AM  Information  Smc   Symantec Management Client is stopped.

Cause



The policy files have become corrupt. 


Solution



 

The following fix was added in 11.0 RU7 MP1:

 

SMC.exe fails to start when the policy file (serdef.dat) is corrupt
Fix ID: 2351705
Symptom: SMC.exe will fail to start when the policy file (serdef.dat) is corrupt.
Solution: SMC.exe will now use the backup.dat and server.dat instead of serdef.dat, if serdef.dat cannot be loaded.

The following fix was added in 12.1 RU1:

SMC.exe fails to start when the policy file (serdef.dat) is corrupt
Fix ID: 2359517
Symptom: SMC.exe will fail to start when the policy file (serdef.dat) is corrupt.
Solution: SMC.exe will now use the backup.dat and server.dat instead of serdef.dat, if serdef.dat cannot be loaded.

 
However if the server.dat and backup.dat policy files are corrupt as well, you will need to replace them with good copies from a working SEP client of the same group, or reinstall SEP.
 
Manual workaround (if unable to upgrade to RU7 MP1 or 12.1 RU1)

1. Delete the serdef.dat and possibly the serdef.dat.bak file.

In Symantec Endpoint Protection 11.x and 12.0, these files are located in

\Program Files\Symantec\Symantec Endpoint Protection\

or

\Program Files(x86)\Symantec\Symantec Endpoint Protection\

In version 12.1.x of Symantec Endpoint Protection, these files are located in:

C:\Users\All Users\Symantec\Symantec Endpoint Protection\CurrentVersion\Data\Config (Windows 7 and 8)

or

C:\Documents and Settings\All Users\Application Data\Symantec\Symantec Endpoint Protection\CurrentVersion\Data\Config (Windows XP)

2. Start the SMC  service.

If the service fails to start, it is likely the server.dat and other policy files are corrupt as well.  Reinstall SEP, or replace the .dat files with known good copies from a working SEP client of the same group.  This will replace any policies previously in place with the policies from the SEP client being used as a source.

Note: If you are unable to delete the files, you can use a tool like the SysInternals "MoveFile" tool to mark them for deletion.  It can be downloaded from the following source:

http://technet.microsoft.com/en-us/sysinternals/bb897556

Manual workaround (if already on 11.0 RU7 MP1 or 12.1 RU1):

In situations where the clients have already been updated to 11.0 RU7 MP1 or 12.1 RU1, this would point to corruption in one of the other policy files used by the SEP client - cltdef.dat, cltdef.dat.bak, server.dat, or backup.dat.  Here are the steps to perform to replace these files:

1. Disable Tamper Protection if it is enabled.
2. Stop SMC (smc –stop)
3. Replace the cltdef.dat, cltdef.dat.bak, server.dat and backup.dat with known-good copies from another client
4. Start SMC (smc –start)
5. Re-enable Tamper Protection

Note: In 11.0 RU7 MP1 and 12.1 RU1 there is no need to manually replace serdef.dat and serdef.dat.bak.

If you use policy files from a different group, the client will change its group in the manager.  You can correct this by moving them from the Symantec Endpoint Protection Manager console after they resume normal communications.

Please contact Symantec Technical Support for further assistance if any difficulty is experienced in identifying which policy is or may be corrupt.

 




Article URL http://www.symantec.com/docs/TECH173484


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