PGP Desktop 10.2 doesn't start with errors - "The program can't start because java.dll is missing from your computer. Try reinstalling the program to fix this problem."

Article:TECH173848  |  Created: 2011-11-08  |  Updated: 2012-10-04  |  Article URL http://www.symantec.com/docs/TECH173848
Article Type
Technical Solution


Issue



PGPtray.exe doesn't start after upgrading from version 10.1.2.50 to 10.2.0.1672.


Error



PGPtray_Hidden_Window: PGPtray.exe - System Error

"The program can't start because java.dll is missing from your computer. Try reinstalling the program to fix this problem."
 

Environment



PGP Desktop 10.2


Cause



The PGP Desktop code, when set to automatic, the software looks for the following driver files:
 

    acpkcs211.dll
    asepkcs.dll
    aetpkss1.dll
    SLBck.dll
    DKck232.dll
    eTpkcs11.dll
    gemplus.dummy
    PKCS11.dll
    cmP11.dll
    P11TCOS3Netkey.dll

 

in the \HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\SharedDlls registry key.  If there is a file listed there that ends in any of these strings, then it will be loaded by PGP Desktop. Use regedit to examine that key to determine if such a DLL referenced.

3rd party applications (i.e.VMware View Agent v4.6, Cisco Unified Personal Communicator) might install drivers ending in one of the strings above which cause issues.

 


Solution



Use one of the following to resolve this issue.

  • As a workaround uninstall the 3rd party application
  • Rename the pkcs12.dll driver
  • Disable automatic token support in PGP  Desktop

 

Note: This issue is fixed in PGP Desktop 10.2 MP3 and newer.

 




Article URL http://www.symantec.com/docs/TECH173848


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