When using pcAnywhere across a WAN the video and file transfer function is extremely slow.

Article:TECH174261  |  Created: 2011-11-11  |  Updated: 2012-08-03  |  Article URL http://www.symantec.com/docs/TECH174261
NOTE: If you are experiencing this particular known issue, we recommend that you Subscribe to receive email notification each time this article is updated. Subscribers will be the first to learn about any releases, status changes, workarounds or decisions made.
Article Type
Technical Solution

Product(s)

Subject

Issue



When working across a WAN, the video and file transfer function is extremely slow.


Error



Poor video performance when connecting to hosts across a VPN connection.


Environment



pcAnywhere solution 12.5 or 12.6 (pre sp2) and 12.6.7
pcAnywhere Box 12.5.5 (AKA sp4)


Cause



By default, the pcA QuickConnect application uses "pcAnywhere" encryption. Some WAN or VPN hardware or software will encrypt all traffic sent and received. It is possible that the encryption of the already encrypted trafic will cause greater delays, and can result in the poor video performance of pcAnywhere.


Solution



A version of the PCAQuickconnectDll.dll file is available that will not force the use of encryption and then the delay that is seen by encrypting the encrypted data won't be seen.

Four versions of the PCAQuickconnectDll.dll are attached to this article. One for each specified version of pcAnywhere or pcAnywhere Solution.  Be sure to download the appropriate version for your environment.

You can determine the build number through the Symantec Installation Manager window for pcAnywhere solution.  For pcAnywhere Box open the pcAnywhere program, navigate to help and about to see the build number.  


Symantec ALWAYS recommends backing up any files or folders, especially the Windows Registry before making any changes.

To apply the patch:

  1. Download the appropriate .zip file from below and extract the file
  2. On the remote computer (from which the remote control connection is made).
  3. Browse to the Symantec pcAnywhere installation folder
    • "C:\Program Files\Symantec\pcAnywhere".
    •  "C:\Program Files (x86)\Symantec\pcAnywhere"
  4. Backup the "PCAQuickconnectDll.dll"
  5. Replace the existing pcAnywhere "PCAQuickconnectDll.dll" file with the file provided in this patch.
  6. Launch pcAQuickConnect and test connecting to a host that is configured to not use any encryption. 
     

 


Attachments

PCAQuickconnectDll.dll for pcA solution 12.5
2476906_-_File_Transfer_is_slow_with_pcA_Quick_Connect.zip (36 kBytes)
PCAQuickconnectDll.dll for pcA solution 12.6 (prior to SP2)
2612956_-_File_Transfer_is_slow_with_pcA_Quick_Connect.zip (36 kBytes)


PCAQuickconnectDll.dll for pcA solution 12.6.7
12_6_7_Sol.zip (35 kBytes)
PCAQuickconnectDll.dll for pcA Box 12.5.5 SP4
12_5_SP4_Box.zip (35 kBytes)

Supplemental Materials

SourceETrack
Value2612956, 2476906,2773156


Article URL http://www.symantec.com/docs/TECH174261


Terms of use for this information are found in Legal Notices