Altiris/NS Application error while loading the Notification Server console.

Article:TECH17428  |  Created: 2005-09-26  |  Updated: 2005-09-26  |  Article URL http://www.symantec.com/docs/TECH17428
Article Type
Technical Solution


Issue



When atttempting to load the Notification Server Console they get the following error:

Server Error in '/Altiris/NS' Application
Runtime Error

Description: An application error occurred on the server.  The current customer error settings for this application prevent the details of the application error from being viewed remotely (for sceurity reasons).
It could, however, be viewed by browsers running on the local server machine.

Details:To enable the datails of this specific error message to be viewable ton the local server machine, please create a <customErrors> tab within a "web.config" configuration file located in the root directory of the current web application.  This <customErrors> tag shoule then have its "mode" attribute set to "RemoteOnly". To enable the details to be viewable on remote machines, please set "mode"to "Off".

<!--Web.config configuration File -->

<configuration>
     <system.web>
          <customErrors mode=Off"/>
     </system.web>
<configuration>

Notes:The current error page you are seeing can be replaces by a customer error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.

<!--Web.config configuration File -->

<configuration>
     <system.web>
          <customErrors mode=On" defaultRedirect="mycustompage.htm"/>
     </system.web>
<configuration>

 


Environment



Notification Server 6.0 sp2

Cause



Insufficient space on the partition with the Altiris Database.

Solution



Moved the Altiris Database to a drive with more available space.

The following steps will help you move a SQL database from one location
to another. Additional Notes can be found at
http://support.microsoft.com/default.aspx?scid=kb;en-us;224071

Please also note that the steps below are for SQL 7 and 2000 only.

Moving the Database files:

1.    Make sure that you have a current backup of all of the databases
you are planning to move.
2.    Stop all of the Altiris Services. These are found on the NS
server, by clicking Progams<Administrative Tools<Services, and stopping
all of the Altiris-related services.
3.    On the SQL server, open up SQL Enterprise Manager, and
right-click the database you want to move. Choose All Tasks<Detach
Database
4.    Verify that current connections are at 0. If not, clear all
connections, by clicking the clear connections button.
5.    Once that is completed, browse to the existing database location
in the file system.
6.    Grab both the .mdf file and the .ldf files for the databases you
would like to move, and move (don't copy, but move) to the desired
location.
7.    Go back to SQL enterprise Manager, Right click on the databases
folder
8.    Select All Tasks<Attach Database
9.    Make sure the database has the same names
10.    Specify that the database owner (DBO) to be same SQL account as
was used when the NS was installed
11.    Click OK
12.    Restart the Notification Server services
13.    Verify database and NS functionality




Legacy ID



2624


Article URL http://www.symantec.com/docs/TECH17428


Terms of use for this information are found in Legal Notices