SCSP agents stopped reporting to the console.
| Article:TECH174357 | | | Created: 2011-11-14 | | | Updated: 2012-03-19 | | | Article URL http://www.symantec.com/docs/TECH174357 |
Problem
Agents are not reporting into the Console. If Console is stopped and restarted, the Agents will then show up.
Environment
Windows Server Std. 2003 SP2
Cause
One cause can be that the transaction log in the database is full.
Another cause can be that there is an inconsistency in a database cluster, where one node of the cluster has more/different data than the other. This can cause an agent to "Disappear" and then "Reappear" at a later date, as the database cluster service switches between cluster nodes.
Solution
The DB has run out of logging space.
This can be checked by looking at the csp-dbinfo.txt file located in the %ProgramFiles%\Symantec\Critical System Protection\Server\ directory (note this is the default location). This file is automatically updated once per day. Search csp-dbinfo.txt for "Database Status Summary" and note the status. A good status will be GREEN/GREEN. If you get a RED/RED or RED/GREEN, then there is an issue with disk space or no backup has been run. You can also search for "transaction log" and the report will tell you the current and max size of the transaction log.
If it is found that the transaction log is full, the current recommendation is the following:
Here are the steps to first back up the database (1-5) and How to shrink the
transaction log (6-13).
1. Use ‘sa’ username to login to SQL Server Database using SQL Server
Management Studio.
2. Expand Databases, and select SCSPDB database.
3. Right click the database and select Tasks->Backup
4. Select Backup Type as Full
5. Click on Add and select a backup destination on an external disk.
• This will back up the entire database and might take a while to execute.
• Please ensure that you have sufficient amount of disk space on external drive.
• Press OK.
6. Right-click the instance, and then click Properties, which opens the
Database Properties dialog box.
7. In the Select a Page pane, click Options.
8. The current recovery model is displayed in the Recovery model list box.
9. Change Recovery model from Full to Simple. Press OK
10. Right-click the SCSPDB database, and then select ->Tasks->Shrink->Files
11. Change File type from Data to Log. Ensure that
• Filename is changed to scsplog
• File location ends with SCSPDBlog.ldf
12. Set Shrink action to Release Unused Space. Press OK
• The above steps should shrink the transaction log. Verify the transaction
log file size on disk.
13. Repeat steps 6 to 9 and set recovery model back from Simple to Full.
Check the tempdb in SQL Server and make sure it isn’t full. If so, use above
steps to shrink it. This can be found under System Databases in SQL Server Management Studio.
In General:
the Database is full message means, the customer needs to review the
following:
1. Data retention plan, specifically how long do you plan to keep SCSP
events in database?
2. Base on retention plan, implement data purging through SCSP manager.
3. Review events that are being logged in database and confirm that they
are truly necessary for logging real time
4. Any event that are for forensic needs for future use or compliance
should be configure to log as bulk logging
Summary:
Review data retention plan and implement event purging.
Review what is being logged in SCSP database and reduce if possible by logging
to bulk logging.
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| Source | ETrack |
| Value | 2637109 |
Article URL http://www.symantec.com/docs/TECH174357
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