GRT Calendar Restore to original location, Exchange resends old Meeting Request Responses

Article:TECH174568  |  Created: 2011-11-16  |  Updated: 2012-01-27  |  Article URL http://www.symantec.com/docs/TECH174568
Article Type
Technical Solution


Environment

Problem



After restoring Exchange calendar, Exchange resends old Meeting Request Responses


Error



After granular restore of calendar to original location, Exchange sends meeting request responses even though they were old items in the past.


Environment



Windows Server 2008 R2
Exchange 2007 & 2010


Cause



When a mail item is restored, a few steps occur:

1) If overwrite original is enabled then the original items is deleted

2) A new item is created

3) The content of the backed up item is restored into the newly created item

 

This of course results in e-mails, contacts or calendar items being seen as new entries within Exchange - and as a calendar item for meetings has a distribute (invites) list as part of it's data it will send out meeting requests.

Note: We can't restore mail items with the original mail identifiers as this would almost certainly upset the transaction logging processs behind Exchange so it has to be a new item. As such although not technically designed to resend the meeting requests it is kind of expected as a consequence of the restore process.Also For the same reason if you restore the same e-mail twice, with overwrite original set, the first restore will 'overwrite' the original e-mail (in fact it will delete it) and the second restore will create a duplicate message in the Inbox of the user, because the message ID from the first restore no longer matches what was backed up so the second restore can't find the message to delete.


Solution



Workaround 1

+ Configure the Message Size Restriction to the selected mailbox: maximum message size: 0 KB

+ Run the Restore to the selected mailbox

+ Logon to the mailbox and delete all the non delivery mails that were created because the old meeting requests tried to get out but the configured maximum message size would not let them out.

+ After the messages were deleted  Change back the Size Restriction for the Mailbox account to it´s default.
 

MIcrosoft Technote References:

Configure Message Size Limits for a Mailbox or a Mail-Enabled Public Folder  Applies to: Exchange Server 2010 SP2

http://technet.microsoft.com/en-us/library/bb124708.aspx

Managing Message Size Limits Applies to: Exchange Server 2007 SP3, Exchange Server 2007 SP2, Exchange Server 2007 SP1, Exchange Server 2007

http://technet.microsoft.com/en-us/library/bb124345(EXCHG.80).aspx

 

Workaround 2 (For Terminated Users Only)

For a User that was terminated - (This will not work for someone that still needs a mailbox access)

To stop the old meetings from being delivered you may set a transport rule to block the messages from the restored user  

MIcrosoft Technote References:

Transport Rules Applies to: Exchange Server 2010 SP2

 

http://technet.microsoft.com/en-us/library/aa995961.aspx

 

 

Transport Rules Applies to: Exchange Server 2007 SP3, Exchange Server 2007 SP2, Exchange Server 2007 SP1, Exchange Server 2007

http://technet.microsoft.com/en-us/library/aa995961(EXCHG.80).aspx

 

 




Article URL http://www.symantec.com/docs/TECH174568


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