Warning "The authenticated user cannot access the requested cube." occurs when trying to access an IT Analytics cube or report

Article:TECH174986  |  Created: 2011-11-21  |  Updated: 2012-09-20  |  Article URL http://www.symantec.com/docs/TECH174986
Article Type
Technical Solution


Issue



When a specific user tries to access an IT Analytics cube or report, a warning appears: "The authenticated user cannot access the requested cube. Please verify that the authenticated user has proper privileges to the requested cube on the SQL Server Analysis Services instance on which it is hosted, and that the client machine has the Microsoft SQL Server Analysis Services 9.0 OLE DB Provider installed."

The same user account, however, may be able to access cubes when logged into the SQL Server or the Symantec Management Platform server, and the service account (Application ID) may work fine on the workstation.


Error



The authenticated user cannot access the requested cube. Please verify that the authenticated user has proper privileges to the requested cube on the SQL Server 2005 Analysis
Services instance on which it is hosted, and that the client machine has the Microsoft SQL Server 2005 Analysis Services 9.0 OLE DB Provider installed. Additionally
check the browser settings for the internet zone this site shows up in and verify that the setting called "Access data sources across domains" under Miscellaneous is set to "Enable" or "Prompt".

Microsoft SQL Server 2005 Analysis Services 9.0 OLE DB Provider is required for the Office Web Components to communicate with Microsoft SQL Server 2005 Analysis
Services. This is a standard component bundled with recent Microsoft products such as Office 2007 and SQL Server 2005 Management Studio, and is also available from the
Microsoft Web site. To download Microsoft SQL Server 2005 Analysis Services 9.0 OLE DB Provider, navigate to the section labeled
"Microsoft SQL Server 2005 Analysis Services 9.0 OLE DB Provider" at the following URL: http://www.microsoft.com/downloads/details.aspx?familyid=df0ba5aa-b4bd-4705-aa0a-b477ba72a9cb&displaylang=en.


Cause



Various.


Solution



Install Microsoft OLE DB Provider and Office Web Components on the workstation that will be using IT Analytics

Two Microsoft components are required to be installed before the user can access IT Analytics cubes and reports from a workstation:
 

  1. The Office 2003 Add-in: Office Web Components (ow11.exe) or comparable Office files must be installed on the workstation. A separate warning about this will occur before the OLE DB Provider error occurs. Download the "ow11.exe" file from the specified URL in the warning and then run it to install it on the workstation.
  2. The Microsoft SQL Server 2005 Analysis Services 9.0 OLE DB Provider must be installed on the workstation. Download either the "SQLServer2005_ASOLEDB9.msi" file for 32-bit Windows operating systems or the "SQLServer2005_ASOLE9_x64.msi" file for 64-bit from the specified URL in the warning and then run it to install it on the workstation. The workstation is required to be rebooted afterwards. If this is already installed, try uninstalling and reinstalling the Microsoft SQL Server 2005 Analysis Services 9.0 OLE DB Provider while logged in as the user account that is to use IT Analytics cubes and reports.
     

Notes:

  • If the component requires the workstation to be rebooted, do so before using IT Analytics cubes and reports again.
  • After these components have been installed, the user may also experience various browser warnings, such as "This website is using your identity to access a data source. If you trust this website, click OK to continue, otherwise click Cancel" each time the user accesses a cube or report. These can be disabled by changing various browser settings, as outlined in the IT Analytics 7.1 SP2 User Guide, page 66, in the "Removing warning messages" section:

    Altiris IT Analytics Solution 7.1 SP2 from Symantec User Guide
    http://www.symantec.com/business/support/index?page=content&id=DOC4837
     

Configure Internet Explorer to allow data source access across domains

If installing the two required Microsoft components do not resolve the issue or they are already installed, next check that the Internet Explorer's setting "Access data sources across domains" is enabled:
 

  1. In Internet Explorer, go to the Tools menu > Internet Options.
  2. Click on the Security tab.
  3. Click on the Custom Level button. Note: If the user's Interment Explorer settings are managed by a group policy (GPO), this may be indicated o this tab such as a "Some settings are managed by your system administrator." message. If so, the user may not be able to change the following. If not, contact the system administrator for assistance in doing so.
  4. In the Miscellaneous section, click the Enable radio button to enable "Access data sources across domains".
  5. Click on the OK button.
  6. Click on the next OK button.
  7. Close the browser.
  8. Open a new browser, and retry using IT Analytics.

Ensure the URL for the SMP has been added to the Trusted Sites and Local Intranet in Internet Explorer.


Data source user security is misconfigured or locked down in the Microsoft Report Manager

Verify that the affected reports can be accessed in the Microsoft Report Manager. Specifically,does any other user account work, such as the system administrator's? If so, this indicates that user-level security is set up, most likely on the data sources in the Microsoft Report Manager. If this is misconfigured, the user may be incorrectly prompted to install the Ole DB Provider or report processing errors may occur.
 

  1. In Internet Explorer, go to the URL http://sql-server-name/Reports, where "sql-server-name" is the computer name of the SQL Server where the SQL Server Report Server (SSRS) is installed to.
  2. Click on the IT Analytics report folder to open it.
  3. A list of IT Analytics reports are displayed, along with two data sources.
  4. Click on the drop down arrow for the ITAnalytics data source and then choose Manage.
  5. In the Properties section, verify that the "Connect using" is set up correctly. It is recommended to use stored credentials. This would be specified by:

    (checked) Connect using: Credentials stored securely in the report server
    User name: domain-name\user-name
    Password: password
    (checked) Use as Windows credentials when connecting to the data source

    Where "user-name" is the domain name and user name that has access rights to fully use SSRS as defined in SQL, and "password" is that user's domain password.
     
  6. If any changes where made, click on the Apply button.
  7. Check the CMDB data source as well and set this up in the same way as from steps 4 through 6.
     

Troubleshooting:
 

  1. Still in the Report Manager, back out of any data source that has been accessed to where all of the reports are now seeing at.
  2. Click on a report to test, such as Computers by Manufacturer.
  3. Does the report work? If not, a report processing error may occur. it's very likely then that user security is still misconfigured. Double check the above instructions.
     

Related Articles

Unable to run IT Analytics reports after upgrading or installing IT Analytics 7.1 SP2
http://www.symantec.com/business/support/index?page=content&id=TECH175120

Error "HTTP 401: Unauthorized" occurs when trying to drill down into IT Analytics reports
http://www.symantec.com/business/support/index?page=content&id=TECH187467

IT Analytics Internet Explorer Browser Settings

http://www.symantec.com/business/support/index?page=content&id=HOWTO65683
 




Article URL http://www.symantec.com/docs/TECH174986


Terms of use for this information are found in Legal Notices