Error 'Windows installer has stopped working' while upgrading the PGP Desktop managed clients to a 10.2.x version prior to 10.2 MP4.

Article:TECH175381  |  Created: 2011-11-24  |  Updated: 2013-05-29  |  Article URL http://www.symantec.com/docs/TECH175381
Article Type
Technical Solution


Environment

Issue



When you try to upgrade the from 10.2 MP1 to 10.2 MP2-10.2MP3HF1 you may get an error 'windows installer has stopped working' with the description 'A problem caused the program to stop working correctly. Please close the program'. When you click 'OK' on this error, the same error comes up again. After clicking on 'OK'  three to four times on the error, the installation proceeds and completes. The client gets upgraded, however the upgrade seems to have issues. If you Repair/Modify the installation, you will still got the same Windows Installer error.


Error



'Windows installer has stopped working' with the description 'A problem caused the program to stop working correctly. Please close the program'.


Environment



PGP 10.2.x (prior to MP4)

Windows 7 32-bit and 64-bit

Windows XP 32-bit

Data Execution Prevention enabled in Windows

 


Cause



There is a known issue with the PGP Desktop installer that is causing these error reports to come up.


Solution



This is a known issue and we have determined that this is unexpected behavior in the software.

This issue has been resolved in 10.2 MP4.

If you are on a version prior to 10.2MP4 (such as MP2 or MP3). It is still possible that you could get the windows installer error popping up again as part of the upgrade to MP4. But the following scenarios have been tested and proved to work with a 10.2 MP4 update of the client:

- PGP Desktop 10.1.2 SP3 on Windows XP--> 10.2 MP4 - No Windows Installer errors

- PGP Desktop 10.2 MP1 on Windows 7 32-bit ---> 10.2 MP4 - No Windows Installer Errors

- PGP Desktop 10.2 MP2 on Windows 7 32-bit ---> 10.2 MP4 - No Windows Installer Errors

After installing 10.2 MP4 (Build 2526) the Windows Installer errors do not come up during the installation and the upgrades completes successfully.




Article URL http://www.symantec.com/docs/TECH175381


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