KNOWN ISSUE: Logged-on user data slowing down axengine

Article:TECH175601  |  Created: 2011-11-28  |  Updated: 2013-01-29  |  Article URL http://www.symantec.com/docs/TECH175601
NOTE: If you are experiencing this particular known issue, we recommend that you Subscribe to receive email notification each time this article is updated. Subscribers will be the first to learn about any releases, status changes, workarounds or decisions made.
Article Type
Technical Solution

Product(s)

Issue



The Deployment Server engine (axengine) is so busy processing logged-on user data from its clients that it experiences severe performance degradation which includes, but is not limited to, jobs failing to run.


Environment



DS 6.9 (all builds)

Citrix and Microsoft Terminal servers with AClient or DAgent installed


Cause



The AClient/DAgent gathers each logged-on user's information and passes that information back to the Deployment Server engine (axengine). The engine then has to process each of these bits of information. Because of their roles, both Citrix and Microsoft Terminal Servers generate high volumes of logged-on user data that trigger the failure described by this article.


Solution



This issue has been resolved by adding a registry key to the Deployment Server and client(s) that opts to ignore changes to the list of logged on users. This registry key will work on AClient 6.9.453 (SP4) or DAgent version 6.9.490 (SP5) and newer.

You will first need to adjust the registry settings on the Deployment Server. Otherwise the changes made to the registry on the client will revert back to their previous setting. This is done here:

HKLM\SOFTWARE\Altiris\Altiris eXpress\Options\UserInfoInterval

Set the value to 0  (REG_DWORD).

The client key location to disable the logged on users reporting to the server:

HKLM\SOFTWARE\Altiris\Client Service\UserInfoInterval

Again, set the value to 0  (REG_DWORD).

This must be done in a specific order:

1: Change the registry settings on the Deployment server.

2: Restart the eXpress server service or restart the Deployment Server.

3: Change the registry setting on the client.

NOTE: These changes to the server will cause ALL clients to stop showing their logged on user.


Supplemental Materials

ValueETK 1947518
Description

Logged in Etrack (Symantec) database


Legacy ID



51740


Article URL http://www.symantec.com/docs/TECH175601


Terms of use for this information are found in Legal Notices