Some items fail to index with 'Object reference not set to an instance of an object'

Article:TECH176143  |  Created: 2011-12-05  |  Updated: 2013-06-12  |  Article URL http://www.symantec.com/docs/TECH176143
Article Type
Technical Solution


Issue



Some items fail to index with the following error: Object reference not set to an instance of an object

 


Error



Excerpt of Index Report:

SeqNo SSID URL Error Code Raw Error
7325 201111030330547~200902190717160000~Z~90AF9E85BAC13F0DE550788F47071891
http //EVServer/EnterpriseVault/download.asp?VaultID=12A2E7E0F1F4053489481740B5BD7E8A21110000EVServer&
SavesetID=201111030330547~200902190717160000~Z~90AF9E85BAC13F0DE550788F47071891&Request=NativeItem
101 Object reference not set to an instance of an object.

 

Dtrace excerpt:

EVIndexVolumesProcessor) <Auditor Thread for 1D8F41F9695A84BD9AD35C2FCA53640E91013b00mailarchive_ 1945D594B91D49F4485A1EACC29B1D49B1013a00EVServer_12A2E7E0F1F4053489481740B5BD7E8A21110000EVServer_27:8996>
EV-L {EVREBUILDSUBTASK.EN_US} 7325|201111030330547~200902190717160000~Z~90AF9E85BAC13F0DE550788F47071891|
http //EVServer/EnterpriseVault/download.asp?VaultID=12A2E7E0F1F4053489481740B5BD7E8A21110000EVServer&
SavesetID=201111030330547~200902190717160000~Z~90AF9E85BAC13F0DE550788F47071891&Request=NativeItem|101|Object reference not set to an instance of an object.

 

Journal Report following a verify:

The report will show that the item is missing and the Reason is: N/A

SeqNo SSID Attach ID URL Missing from Index Orphaned item MissingContent Reason
323038 201110077992414~201110071255120000~Z~80F1112D0E25C35EDB3DE5D60D739AC1 N/A
http //EVServer/EnterpriseVault/download.asp?VaultID=174B4974592C18247AE9CAD78A91EA4871110000EVServer&
SavesetID=201110077992414~201110071255120000~Z~80F1112D0E25C35EDB3DE5D60D739AC1&Request=NativeItem True False N/A


Environment



The problem has been reported under the following version(s):
- Enterprise Vault 10.0.0 (Base Version)


Cause



When the Indexing process encounters an empty tag for the Display Name or Email Address in the XML Stream of an item, this item failed to index.


Solution



This issue has been addressed by the following:

Enterprise Vault 10.0 Hotfix: 
http://www.symantec.com/docs/TECH176975 

Enterprise Vault 10.0.1
http://www.symantec.com/docs/TECH147787


Supplemental Materials

SourceETrack
Value2631257
Description

Failing to index an item because of a null-reference exception




Article URL http://www.symantec.com/docs/TECH176143


Terms of use for this information are found in Legal Notices