Right click menu fails to work when using a custom report or custom resource

Article:TECH176318  |  Created: 2011-12-06  |  Updated: 2014-10-06  |  Article URL http://www.symantec.com/docs/TECH176318
Article Type
Technical Solution


Issue



When trying to use the right click context menu on a custom report or a custom resource (that may be using a custom report or an out of box report), the right click menu fails to appear, preventing the creation or editing of the resource.


Cause



The report being used by the resource does not have a right click context menu defined.


Solution



Edit the report and add a right click context menu.
 

  1. In the Symantec Management Platform Console, click on the Reports button.
  2. Locate the report to edit. If this is an out of box report, first clone this report to edit, and then associate it with the resource type in question (from Settings > All Settings > Service and Asset Management > Resource and Data Class Settings > Resource Types).
  3. Click on the report's Edit button.
  4. Click on the Drilldowns tab.
  5. In the Drilldown section, click on the Add button.
  6. Change the Name value to ShowContextMenu.
  7. In the Action Wireup section, set Available On to be MyGridView.
  8. Set Event to Right-Click.
  9. Set Performs to Show Context Menu.
  10. In the Action Configuration section, set the drop-down to be _ItemGuid or otherwise a GUID reference. If none exist, this must be specified in the report's columns or SQL, such as:

    SELECT
    vAsset._ResourceGuid AS '_ItemGuid',
    vAsset.Name

    Etc.
     
  11. Click to enable "Display additional resource tool items in the menu".
  12. Click on the Save Changes button.
  13. If this does not enable the context menu, verify if the logged in user's security role is part of a limited or custom security role that may not normally have permission to edit the resource to begin with, or, if the resource or user is part of a hierarchy, where permissions may also be limited in. If the user does not have sufficient Console permissions, this must be changed in the Security section of the Console (which is not covered by this article).
     

Related Articles

How to enable double click editing of assets in a custom report
http://www.symantec.com/business/support/index?page=content&id=HOWTO83282

How to use drop-down lists in a custom report
http://www.symantec.com/business/support/index?page=content&id=HOWTO83270

How to add columns or tables to a custom SQL report
http://www.symantec.com/business/support/index?page=content&id=HOWTO84069

Errors occur while editing a cloned or custom report
http://www.symantec.com/business/support/index?page=content&id=TECH200851

Unable to right click or create/edit certain Configuration Items reports, such as Services
http://www.symantec.com/business/support/index?page=content&id=TECH205844

How to create a custom report for assets
http://www.symantec.com/business/support/index?page=content&id=HOWTO100089




Article URL http://www.symantec.com/docs/TECH176318


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