Windows PE and Bart PE incompatibility with Symantec Encryption Desktop (formerly known as PGP Desktop) 10.2

Article:TECH177520  |  Created: 2011-12-21  |  Updated: 2014-05-07  |  Article URL http://www.symantec.com/docs/TECH177520
Article Type
Technical Solution


Issue



The Windows PE image and ISO is built successfully. But once you are able to successfully boot inside the PE environment and attempt to run pgpwde commands from a command prompt you may encounter problems such as the ones listed below.


Error



  • a pop-up appears that says "System Error - pgpcl.dll is missing from your computer"

  • If you are using Symantec Encryption Desktop 10.2 MP3 you might still see "PGPcl count not find string path"

  • The commands appear to execute correctly but they don't actually do anything including produce an output


Environment



Symantec Encryption Desktop 10.2 Build 1672 or newer

Windows PE x86 2.0 or 3.0

BartPE


Cause



There were some fundamental changes to the SDK for Symantec Encryption Desktop in the 10.2 release. Some of these changes require more .dll files to be included in the image when creating the winpe.wim file and generating the WinPE.iso file. 


Solution



Although Symantec Encryption Desktop 10.2 MP3 would display the "PGPcl count not find string path", error when running pgpwde commands, the commands would still run successfully.  This was due to changes made in the initialization strings for Encryption Desktop version 10.2.

All of these issues are resolved with Encryption Desktop 10.2 MP3 HF1 (Build 2401) and above and have been verified to fix the problem. Due to these changes in the SDK and the code changes made in Symantec Encryption Desktop Build 2401 and newer, the process to build the WinPE image is different and requires more .dll files and .sys files to be included in the c:\wde path when building the winpe.wim image file.

See HOWTO64225  for information on how to build WinPE environment for an Encryption Desktop 10.2 environment with 10.2 Build 2401 or newer installed.

 

The instructions in the guides for customizing the BartPE or BartPE-based tools was a feature that worked in early versions of Symantec Drive Encryption, but have not been supported for versions 9.12 and beyond and are no longer supported.

 





Article URL http://www.symantec.com/docs/TECH177520


Terms of use for this information are found in Legal Notices