System Requirements for LiveUpdate Administrator 2.3.1 and 2.3.2

Article:TECH177544  |  Created: 2011-12-21  |  Updated: 2013-08-27  |  Article URL http://www.symantec.com/docs/TECH177544
Article Type
Technical Solution


Issue



You require guidance on what the system requirements are for installing and running LiveUpdate Administrator 2.3.1 (LUA 2.3.1) and 2.3.2 (LUA 2.3.2).


Environment



LUA 2.3.x


Solution



The system requirements for LiveUpdate Administrator 2.3.1 and 2.3.2 are as follows:

Hard disk space

  • The installer package is approximately 150 MB. This includes the Java Runtime Environment (JRE) that is required for LiveUpdate Administrator to function.
  • When installed, the LUA application will take up approximate 200 MB of hard disk space
  • 10 GB of hard disk space is recommended for the Manage Updates folder and for the temporary download folder ( \TempDownload ). 
Note that the amount of space ultimately required by a LUA 2.x server will depend on what products and components are configured, what Distribution Centers are in use, and what purge settings are set for the retention of older files.  Additional information can be found in the article Managing LiveUpdate Administrator 2.x Space Usage in Symantec's Connect forum.

 

Software

  • Windows 2008 Server (including R2).  
  • Windows 2003 Server or Advanced Server with Service Pack 2 or higher
  • Windows 2000 Server or Advanced Server with Service Pack 4 or higher
  • Windows XP Professional with Service Pack 3
  • Windows Vista
  • Windows 7
  • Java™ Runtime Environment (JRE) 1.6 (32-bit). 64-bit Java not supported on any OS.
  • Internet Explorer 8.0, 7.0 and 6.0, Firefox 3.x.
  • TCP/IP network protocol

Please note that LiveUpdate Administrator is not supported on Server Core, the minimal server installation option for Windows Server 2008 or later.  

Hardware

  • 3.2 GHz Intel Pentium 4 CPU or equivalent.
  • 1 GB of RAM minimum (2 GB of RAM recommended), in addition to the amount recommended by the operating system vendor.

Notes

  • 64-bit and 32-bit operating system versions are supported except for Windows XP 64-bit.
  • The use of a Server OS is strongly recommended for production environments.  Desktop OS's like Windows XP and Windows 7 are not designed to support the number of connections, network bandwidth, storage space and other requirements of a server product.
  • Operating Systems running as guests in virtual environments (such as on VMware ESXi or Microsoft Hyper-V) are supported.

By default, the following ports are used by the Symantec LiveUpdate Administrator.
 

  • 7070 - Used by the Symantec LiveUpdate Administrator.
  • 7071 - Used by Tomcat for shutdown commands. While the Symantec LiveUpdate Administrator will work if this port is closed, Tomcat shutdown operations will not.
  • 7072 - Used by PostgreSQL database.

If these ports are being used by other applications when installing the Symantec LiveUpdate Administrator, the installer will prompt for alternate port numbers that the Symantec LiveUpdate Administrator can use.

If a firewall is enabled for IP packets sent from the Symantec LiveUpdate Administrator system, destination IP ports such as HTTP (80), HTTPS(443), and FTP(21), should be allowed for communication.  The Symantec LiveUpdate Administrator communicates with the Distribution Centers using these ports.

 





Article URL http://www.symantec.com/docs/TECH177544


Terms of use for this information are found in Legal Notices