Symantec Endpoint Protection clients intermittently show offline in the Symantec Endpoint Protection Manager

Article:TECH178661  |  Created: 2012-01-10  |  Updated: 2014-02-10  |  Article URL http://www.symantec.com/docs/TECH178661
Article Type
Technical Solution


Subject

Issue



The status of Symantec Endpoint Protection (SEP) clients switches between "online" and "offline" in the Symantec Endpoint Protection Manager (SEPM) intermittently. SEPM Replication may also fail.


Error



 The following error can be seen in the SEPM's err.log:

01/09 09:01:19. *** ERROR *** Assertion failed: 200114[sem5] (11.0.1.2472)
Can't find values for row ee263:1d in index 'I_SEM_COMPLIANCE_LOG_IDX_PLUS'

 The following error can be seen in the SEPM's scm-server0.log and/or scm-server1.log:

java.sql.SQLException: [Sybase][ODBC Driver][SQL Anywhere]Unable to find in
index 'I_SEM_AGENT_COMPUTER_ID_PLUS' for table 'SEM_AGENT'
at ianywhere.ml.jdbcodbc.jdbc3.IIPreparedStatement.executeUpdate(Native Method)
at ianywhere.ml.jdbcodbc.jdbc3.IPreparedStatement.executeUpdate(IPreparedStatement.java:299)
at org.apache.tomcat.dbcp.dbcp.DelegatingPreparedStatement.executeUpdate(DelegatingPreparedStatement.java:105)
at org.apache.tomcat.dbcp.dbcp.DelegatingPreparedStatement.executeUpdate(DelegatingPreparedStatement.java:105)
at com.sygate.scm.server.statereader.sep.StateHandler.process(StateHandler.java:581)
at com.sygate.scm.server.statereader.sep.StateHandler.process(StateHandler.java:142)
at com.sygate.scm.server.statereader.StateHandlerWorker.processStateData(StateHandlerDispatcher.java:307)
at com.sygate.scm.server.statereader.StateHandlerWorker.run(StateHandlerDispatcher.java:259)
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
at java.lang.Thread.run(Thread.java:662)

 


Cause



This problem happens when one of the SQL database indexes used by the SEPM to increase SQL query efficiency is not present. The missing index is called I_SEM_COMPLIANCE_LOG_IDX_PLUS. This generally happens when a SEPM SQL database is restored from an older backup that doesn't contain this index.


Solution



This problem was fixed in Symantec Endpoint Protection (SEP) 12.1 Release Update 1 Maintenance Patch 2 (RU1 MP1). For more information on downloading the latest version of SEP, see Obtaining the latest version of Symantec Endpoint Protection or Symantec Network Access Control.


Supplemental Materials

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Value2659915

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Value2612223

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Value2620816

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Value2710490



Article URL http://www.symantec.com/docs/TECH178661


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