ServiceDesk global session deleted - portal is active, but no tasks can be executed

Article:TECH179823  |  Created: 2012-01-25  |  Updated: 2012-04-17  |  Article URL http://www.symantec.com/docs/TECH179823
Article Type
Technical Solution

Product(s)

Issue



A environmental problem will cause the global session delete function to be activated, deleting the global session for a user, but also locking up the application pools for ProcessManager, IncidentManagement, and the Feeder forms, if multiple application pools are so configured.

Users will be able to login to the portal, open process views on incidents and changes, but will NOT be able to run any Smart Tasks, open any of the feeder forms, etc.

SD.IncidentManagement will begin to stream a variety of user permission errors as well.

 


Error



These are representative of log entries:

In the Ensemble2006.log

Error,Thursday, January 19, 2012 9:38:16 AM,[global] Error in Login Authentication, SessionID 'd92ca374-84c6-409e-92be-76e19aee9ca7' not found.
[global] Client Host Information:
[global] IP: XXX.XXX.XXX.XXX
[global] HostName: XXX.XXX.XXX.XXX
[global] Browser: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.1; Win64; x64; Trident/4.0; .NET CLR 2.0.50727; SLCC2; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; InfoPath.3; Tablet PC 2.0; .NET4.0C)
[global] -- error.ToString() --
[global] System.Web.Services.Protocols.SoapException: Verify Session ID failed
[global]    at LogicBase.Ensemble.Userman.Userman.VerifySession(String sessionID, String[] permissions)
[global]    at LogicBase.Ensemble.Global.Application_AuthenticateRequest(Object sender, EventArgs e)
 

In SD.IncidentManagement.log

Error,Thursday, January 19, 2012 9:47:23 AM,Error capturing component data. System.Web.Services.Protocols.SoapException: User doesn't have one or all of these permissions ('ProcessData.Access').
   at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)
   at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)
   at LogicBase.Core.Ensemble.ReportingStorageGateway.ReportingStorageGatewayService.GetNextReportIdentity(String sessionID, String forType)
   at LogicBase.Components.Ensemble.Reporting.ProcessManagerReportingSequenceGenerator.GetNextReportIdentity(String prefix, IData data)
   at LogicBase.Components.Ensemble.Reporting.LogMessageProcessComponent.Capture(IData data, IOrchestrationComponent component, String path, ReportingTriggerEvent reportingEvent)

 


Environment



ServiceDesk 7.1 SP1, and 7.1 SP2

(This may be occurring in 7.0 versions, but has not been reported.)

 


Cause



Something in the environment is causing the code to believe that the global user session should be deleted, and that code is being activated and deleting the sessions.


Solution



Two new dll files, Logicbase.Core.dll and Logicbase.Ensemble.Core.dll are required to fix this issue. 

The DLL's to fix the issue in ServiceDesk 7.1 sp1 are contained in an internal KB article - TECH179824, which Symantec Support can provide. 

ServiceDesk 7.1 sp2 fix dll's are included in the Workflow 7.1 sp2 rollup. Contact support for HOWTO65754 "Workflow 7.1 SP2 Point fix Rollup"
Warning: the Point fix has not gone through quality control and testing and so must be installed 'and tested' on a SD dev server for at least 24 hours.

This issue has been addressed in the next release of ServiceDesk.





Article URL http://www.symantec.com/docs/TECH179823


Terms of use for this information are found in Legal Notices