none of the requested files were backed up (2) while trying to backup SQL database
| Article:TECH180015 | | | Created: 2012-01-26 | | | Updated: 2012-10-24 | | | Article URL http://www.symantec.com/docs/TECH180015 |
Problem
- Unable to backup sql database we getting error 2
Error
Under job details we see following error
01/21/2012 21:01:32 - Info bphdb (pid=12528) Backup started
01/21/2012 21:02:28 - Error bpbrm (pid=4382) from client Client Name: ERR - command failed: none of the requested files were backed up (2)
01/21/2012 21:02:28 - Error bpbrm (pid=4382) from client Client Name: ERR - bphdb exit status = 2: none of the requested files were backed up
01/21/2012 21:02:30 - Info bphdb (pid=12528) done. status: 2: none of the requested files were backed up
01/21/2012 21:02:30 - end writing
01/21/2012 21:17:34 - Info nbjm (pid=26570) starting backup job (jobid=14753792) for client Client Name, policy Client Name_sql_full, schedule Full_D
none of the requested files were backed up (2)
When we check DBclient logs we see following error
12:23:33.277 [7732.9008] <2> vnet_connect_to_service: ../../libvlibs/vnet_connect.c.174: 0: connect_to_service() failed: 6 0x00000006
12:23:33.277 [7732.9008] <2> bprd_connect: vnet_connect_to_service(Master server IP ) failed: 6
12:23:33.277 [7732.9008] <2> bprd_get_features: bprd_connect(Master server IP) failed, cannot connect on socket (25)
12:23:33.277 [7732.9008] <16> bsa_checkFeatureId: unable to check if feature <33> is licensed
12:23:33.277 [7732.9008] <16> bsa_checkFeatureId: Server exit status = 25: cannot connect on socket
12:23:33.277 [7732.9008] <16> VxBSAInit: ERR - The license for the requested feature is not available.
12:23:33.277 [7732.9008] <4> VxBSAGetEnv: INF - entering GetEnv - NBBSA_DEBUGFD
Environment
Netbackup 7.1
Windows server 2003
Windows SQL server 2005
Cause
- Issue is caused due Mismatch name of master server and client in the Policy and Script
Solution
-Check if Reverse lookup is working for this client.
-Make sure bpclntcmd -pn command on the client returns correct value.
-We were getting issue as the server Value on the client under HKLM/Software/Veritas/Netbackup/Config contains IP Address
-Added the Netbackup server name under the Server Value.
-Changed the SQL script to use Netbackup server name instead of Using Netbackup Server IP.
-Under the Bar GUI go to Netbackup Client Properties and change the Client server to Short name from FQDN.
-Now Try running the backup job it should work.
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Article URL http://www.symantec.com/docs/TECH180015
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