Alerts not being displayed under the “Alerts” page in Symantec Data Insight Management Server Web GUI Console
| Article:TECH180143 | | | Created: 2012-01-30 | | | Updated: 2012-02-10 | | | Article URL http://www.symantec.com/docs/TECH180143 |
Problem
Alerts of access in DI share not being generated even though the share is being accessed and alert notifications email is being sent correctly and recipients received the emails.
Error
No alerts in GUI
Environment
- Microsoft Windows Server 2008 R2 with the Symantec Data Insight 2.5.1 and 2.5.2
- Microsoft Windows Server 2003 R2 with the Symantec Data Insight 2.5
Cause
Possible causes for this include:
- The alerts_master.db and alerts_email.db may have been corrupted at some point.
- The Minimum Accesses per day for the policy is not met.
- There are no policies configured.
Solution
An alert is a signal generated by a policy when the condition specified in the policy is evaluated as true. The alert get generated whenever the policies are executed with the threshold values are met. The Minimum Accesses per day for the policy is set to 100 (default value). The alert not triggered when the number of accesses in DI share is less than threshold 100.
To get the alerts working, the following steps need to be performed on the Management Server:
1. Verify that the Data or User Activity Policies are configured correctly.
2. Close the Symantec Data Insight GUI Console
3. Navigate to C:\DataInsight\data\alerts
4. Make a copy of the “Alerts” folder to the temporary location (For example: Alerts_Backup folder)
5. Delete the two DB files “alerts_master.db and alerts_email.db” from C:\DataInsight\data\alerts.
6. Open a command prompt and execute the following command:
C:\Program Files\Symantec\DataInsight\bin\configcli execute_job PolicyJob webserver
Note: By default, the configcli.exe configuration utility file is located here: C:\Program Files\Symantec\DataInsight\bin\
7. Open the Symantec Data Insight GUI Console
8. Login and select Alerts tab, the alert should now shows an Data Activity Trigger Policy.
9. If no alerts have been generated, generate some accesses on DI Share and run the policy again to trigger alerts.
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Article URL http://www.symantec.com/docs/TECH180143
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